When launching virtualbox, the icon appears in the launcher and disappears. Virtualbox does not open. In the terminal, I run it and get this:

VirtualBox: Error -610 in supR3HardenedMainInitRuntime!
VirtualBox: dlopen("/usr/lib/virtualbox/VBoxRT.so",) failed: <NULL>

VirtualBox: Tip! It may help to reinstall VirtualBox.

I've tried reinstalling. I've done this too:

sudo chown root:root /usr 
sudo chown root:root /usr/lib

Any help is appreciated. Thank you

The result of ls -la /usr

drwxr-xr-x  10 root root  4096 Oct  3 10:20 .
drwxr-xr-x  24 root root  4096 Dec 14 17:41 ..
drwxrwxrwx   2 root root 69632 Jan 28 19:29 bin
drwxrwxrwx   2 root root  4096 Oct 30 19:41 games
drwxrwxrwx  44 root root  4096 Nov 25 10:51 include
drwxrwxrwx 146 root root 12288 Jan 28 19:29 lib
drwxrwxrwx  10 root root  4096 Oct  3 10:20 local
drwxrwxrwx   2 root root 12288 Dec 17 19:36 sbin
drwxrwxrwx 318 root root 12288 Jan 28 19:29 share
drwxrwxrwx  11 root root  4096 Jan 28 19:29 src
  • This is likely caused by this virtualbox.org/ticket/16759 -- If you chowned the /usr/* directories before, perhaps you did so recursively. Can you confirm /usr/* has original permissions? – Ken Kinder Jan 29 at 1:01
  • Like a noob, I didn't check to see what they were originally. Currently they are at 751 (drwxr-xr-x)? – technicallyblue Jan 29 at 1:09
  • But you didn't change the ownership before? What's the output of ls -la /usr? – Ken Kinder Jan 29 at 1:10
  • That didn't paste well, but /usr/* directories are owned as root, like normal? You didn't do anything in the past that might have changed them? – Ken Kinder Jan 29 at 1:12
  • Guess you can tell this is my first stackexchange post – technicallyblue Jan 29 at 1:15


Welcome to the forum. Ken Kinder's comment was spot on the mark. I am running VBox 5.2.18_Ubuntu r123745 (with extension pack) on Juno -- no problems (so far).

However, your stated POSIX permissions on your /usr directory you stated were (751). From the directory listing you gave they appear to be (777). That does not match my fresh installation of Juno.

Performing a chmod on the entire /usr directory is not recommended. I highly urge you to reset it to 755 as soon as possible. That command would be:

sudo chmod -R 755 /usr

You have already set the /usr and /usr/lib folder owner to root (which is the correct user). After the chmod command has finished, I recommend a reboot. After the reboot, completely uninstall virtualbox and all of its settings with the following command:

sudo apt purge virtualbox

Then you can reinstall Virtualbox the usual way (AppCenter or sudo apt install virtualbox). Good luck! If you continue to experience odd problems, it may be necessary to reinstall Juno. However, don't jump through those hoops unless you are forced to do so...

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.