2

i have one problem with my Code, i cant run it from terminal but from GUI sometimes work sometimes wont open and have some errors when open, i am reinstalled it couple of times but nothing, i was deleted ./locale/share/io.elementary.code folder but nothing happens. whan i run from terminal i got this:

milos@mobileWS:~$ io.elementary.code
[WARNING 11:57:50.838753] [GLib-GObject] invalid cast from 'CodeWelcomeView' to 'ScratchWidgetsDocumentView'
Segmentation fault
milos@mobileWS:~$ io.elementary.code --new-window
[WARNING 11:58:05.479810] [GLib-GObject] invalid cast from 'CodeWelcomeView' to 'ScratchWidgetsDocumentView'
Segmentation fault
milos@mobileWS:~$ io.elementary.code %U
[WARNING 11:58:14.884610] [GLib-GObject] invalid cast from 'CodeWelcomeView' to 'ScratchWidgetsDocumentView'
Segmentation fault
milos@mobileWS:~$ io.elementary.code --new-tab
[WARNING 11:58:28.214672] [GLib-GObject] invalid cast from 'CodeWelcomeView' to 'ScratchWidgetsDocumentView'
Segmentation fault
milos@mobileWS:~$ 

and there is some pictures when try to open from GUI, first one is width options New Window and second is with New Document:

open with option New Window

open with option New Document

  • Did you delete ./local/share/io.elementary.code or ~/.local/share/io.elementary.code? – Ken Kinder Jan 29 at 1:08
  • i did numerous time. :( – Miloš Stevanović Jan 29 at 18:58
  • I had a similar problem, and it turned out that having run code once as root, made the folder in which it keeps it's temp files root owned. Check if that's the case, and chown it if so. – user3801839 Feb 2 at 16:17
  • I delete /root/.local/share/io.elementary.code and /home/milos/.local/share/io.elementary.code and reinstall code with sudo apt remove io.elementary.code and follow with sudo apt autoremove. Than i install io.elementary.code again but still i have problem. Any suggestion? – Miloš Stevanović Feb 4 at 6:20
0

These symptoms sound like an issue that has been reported and now fixed related to certain plugins crashing Code: https://github.com/elementary/code/issues/619

A new version incorporating the fix was released in early March 2019.

For future reference, it is possible to reset all of Code's preferences to default with the following command in the terminal:

dconf reset -f /io/elementary/code/

This often resolves issues with code relating to plugins or documents its trying to re-open that are causing issues.

  • i was reinstall code after March and don't have issue anymore, but forgot to post experience here ;) thanks for answer ;) and explanation ;) – Miloš Stevanović May 7 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.