0

Recently I have to delete my swap partition in order to install Windows 10 (install srceen said something 'bout having too much partition on my drive). Now every time I run elementary os or other linux distro (which have been reinstalled due to shenanigans and worked OK), there's like a pause (over 10s of something) of just the blinking cursor before the computer prints out this line:

Gave up waiting for suspend/resume device

and start booting normally. And as for shutdowns, the system prints something like

"a stop job is running for section c2 of user user XXXX (xx/24s)"

before shutdown. For the former issues, I have tried creating a swap file (with the instructions form This article), then change /etc/fstab to:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda8 during installation
UUID=fa6b3b5e-904d-4a50-8c4f-5993c38937f2 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
#disable swap
#UUID=4dcc1eb2-c8dc-4b4a-bed3-ab53f581a0ff none            swap    sw              0       0
/swapfile swap swap defaults 0 0

and edited "/etc/initramfs-tools/conf.d/resume" to "RESUME=UUID=none" commented (basically deleted) the line with seemingly no effect to the problem.

Another thing is that, in the installation of Windows, I accidentally deleted all my Linux partitions. So I aborted the installation, tried to recover the partitions with testdisk- which thankfully worked- then started the installation again. I did run sudo fsck -f (which turns in clean) and the root partitions' UUID seems to be unchanged so I don't know if this have anything to do with the problems.

It isn't that much an serious issue to me as it's still relatively quick to log in/out of the os. But I would be more happy if those delay were fix and gone.

0

I guess the swap-partition is still listet in your /etc/fstab ? If so, try to uncomment this line in /etc/fstab with a hashmark and reboot. Messed up UUIDs in a fstab can cause this mentioned behaviour.

  • I did do that quite some time ago then add this /swapfile swap swap defaults 0 0 for the swap file. I am wondering if there is other places that has outdated UUIDs which might have caused this. – Sơn Nguyễn Jan 29 at 8:50
  • I don't know if defaults is the correct mount option. Did you try "sw" instead, like this entry for example?: "/swapfile none swap sw 0 0" Another question is, do you really need a swapfile? – Sebastian Jan 30 at 9:55
  • I'll try that. And yes, although it's rarely been a problem to me, you never know when you'll need some sort of RAM overflow (that's what swaps does, right?). And also I only have 4 G of RAM. :P – Sơn Nguyễn Jan 31 at 6:31
  • Update: No effect. I even tried to comment the line (basically make the system ignore that line) then reboot and nothing happen. So I don't think that's the problem. – Sơn Nguyễn Jan 31 at 6:59
  • Normally you should see the partition he is complaining about in the message. Use blkid and compare the UUIDs. Maybe there is a mistake in an entry. Did you update your initramfs after changing to swapfile? – Sebastian Feb 1 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.