Just installed elementary os. in the terminal, ll gives a list of files and directories showing directories with lightblue color with green background - which is unlucky with respect to contrast, hardly can read anything. also this looks screaming.

What is the most simple way to change this theme? I installed dconf Editor and believe I could set a custom value for


Just do not know where to get more reasonable values for that. And not sure if this is the right point too.

3 Answers 3


Try Elementary Tweaks, as described here (https://itsfoss.com/install-elementary-tweaks-in-elementary-os-freya-luna/). It will appear in Settings panel.

enter image description here enter image description here

  • looks good, but unfortunately the 3rd command for installation gives an error: sudo apt-get install elementary-tweaks -° Unable to locate elementary-weaks
    – citykid
    Jan 26, 2019 at 9:29
  • looks like tweaks are not maintained no more: superuser.com/questions/823691/…
    – citykid
    Jan 26, 2019 at 9:31
  • this allows changing background color, not the problem of the colors in the terminal, like green-blue letters with green background for folders - making them perfectly unreadable.
    – citykid
    Mar 9, 2019 at 19:29

In the terminal, you can use the following command.

gsettings set io.elementary.terminal.settings background '#090921111a1b'

The Hash #090921111a1b is broken down to #RRRRGGGGBBBB in base16 0-f

When you have what color you like, place the command in your .bashrc file.

  • Thank you, I tweaked some gsettings already and your answer is generally right. I wanted to change the theme not only the background however. A big problem is the crying color of folders that makes them unreadable instead of highlighting them.
    – citykid
    Mar 7, 2019 at 6:56

Was headbutting this problem as well just now. Same deal, just installed Elementary OS and some of the Directories had Blue text on Green background. Although, I seem to have the same issue on my Ubuntu Server which I most often connect to through Putty witch seems to override the colors.

I found that the problem lies within bash, or at least a simple solution lies in bash. In your home folder, edit the file ".bashrc"

Add these two lines at the end of the file.

LS_COLORS='ow=0;40:di=1;36:'; export LS_COLORS

Then run command "source .bashrc" You could also play with the values for 0;40 and 1;36. As I understand it "di=" sets the color for your normal directories, while "ow=" seems to set the colors for directories where non-owners lack write permission.

This guide had some useful info on setting the bash-colors. https://askubuntu.com/questions/466198/how-do-i-change-the-color-for-directories-with-ls-in-the-console

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.