2

My two WiFi printers show up but are listed as "Disabled". I cannot find any way to enable them. Any suggestions? They work perfectly on my Linux Mint laptop.

Screenshot

1
  • I have 1 wired Samsung CLX-3185 network printer and a HP wireless printer that comes up disabled also. Tried the about but did not work. I want to change from Win 10 and have tried many linux operating systems and I found this one the best for me and my family as I am new to Linux. What a great pity there is this bug (why dont they fix it) every thing else works for me but I guess I am back to Windows
    – butty
    May 24, 2019 at 14:12

3 Answers 3

2

I had the same issue with my WiFi Epson XP332. This is a wrong configured and delivered CUPS-problem. I solved it by changing the cups authorization in /etc/cups/cupsd.conf. I changed the most the settings to "order allow,deny". Then you sholud be able to activate the printer in the settings menu or with usr/sbin/cupsenable PRINTERNAME. Maybe possible that you must reload the CUPS-daemon.

I think is a very huge bug. eOS is told to be user-friendly, so the printing must work out of the box. You cannot annoy new users with such a bitchy printer behaviour.

1

I just ran into this on elementary OS 6.1, so the issue still remains 2.5 years after this question was asked.

One thing I noticed was that if I add my user to the lpadmin group then I can at least print. The printer still shows as Disabled in the System Settings Printers tool though.

To add yourself to the lpadmin group just do the following:

sudo adduser <YOURNAME> lpadmin

where <YOURNAME> is you account name. You then need to log out and back in again.

Using the CUPS web interface (localhost:631) I can manage the printer just fine after making this change too.

0

I have this same issue with an HP ENVY 5000 series. It did start working temporarily and I managed to delete the printers marked disabled, but as soon as I ran system-config-printer to rename the Printer description, the disabled one returned. Incidentally you can add the printer using the CUPS web administration http://localhost:631/admin

Oddly I have 2 machines displaying this and they both appeared correctly after installing Thunderbird and Wordpress client, but both have since returned with a Printer listed as disabled. For me it is now just a cosmetic thing in the printer settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.