1

My two WiFi printers show up but are listed as "Disabled". I cannot find any way to enable them. Any suggestions? They work perfectly on my Linux Mint laptop.

Screenshot

  • I have 1 wired Samsung CLX-3185 network printer and a HP wireless printer that comes up disabled also. Tried the about but did not work. I want to change from Win 10 and have tried many linux operating systems and I found this one the best for me and my family as I am new to Linux. What a great pity there is this bug (why dont they fix it) every thing else works for me but I guess I am back to Windows – butty May 24 at 14:12
1

I had the same issue with my WiFi Epson XP332. This is a wrong configured and delivered CUPS-problem. I solved it by changing the cups authorization in /etc/cups/cupsd.conf. I changed the most the settings to "order allow,deny". Then you sholud be able to activate the printer in the settings menu or with usr/sbin/cupsenable PRINTERNAME. Maybe possible that you must reload the CUPS-daemon.

I think is a very huge bug. eOS is told to be user-friendly, so the printing must work out of the box. You cannot annoy new users with such a bitchy printer behaviour.

0

I have this same issue with an HP ENVY 5000 series. It did start working temporarily and I managed to delete the printers marked disabled, but as soon as I ran system-config-printer to rename the Printer description, the disabled one returned. Incidentally you can add the printer using the CUPS web administration http://localhost:631/admin

Oddly I have 2 machines displaying this and they both appeared correctly after installing Thunderbird and Wordpress client, but both have since returned with a Printer listed as disabled. For me it is now just a cosmetic thing in the printer settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.