1

I just bought a new dell XPS 13 for work and everything is working smoothly except the external monitor and it's pretty annoying to be tied to the small 13 inch display

I bought an usb C to HDMI cable with thunderbolt 3 support, tested it with my phone and it works on my hdmi screen

but when I plug my laptop I have no signal message

when I run lspci -tv with the display plugged, I got :

+-1c.4-[03-6d]----00.0-[04-6d]--+-00.0-[05]-- | +-01.0-[06-38]-- | +-02.0-[39]----00.0 Intel Corporation JHL6540 Thunderbolt 3 USB Controller (C step) [Alpine Ridge 4C 2016] | -04.0-[3a-6d]--

when I run xrandr -q I have

Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 8192 x 8192 eDP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 294mm x 165mm

DP-1 disconnected (normal left inverted right x axis y axis)

DP-2 disconnected (normal left inverted right x axis y axis)

any clue on how to get external display working ?

  • Is the output of xrandr -q any diferent when it's unplugged? Also, do you know whether your external monitor is DisplayLink or DisplayPort? – Ken Kinder Jan 21 at 16:10
  • xrandr -q output is the same when it's unplugged. the monitor I used to test is a regular tv, so I thing it's a DisplayLink – m0ntassar Jan 22 at 16:31
  • Do you happen to have the model of cable handy? – Ken Kinder Jan 22 at 16:52
  • yep amazon.fr/… – m0ntassar Jan 23 at 8:54
0

From your Amazon link in the comments, you appear to have a DP Alt Mode cable, which essentially uses USB C Port for DisplayPort protocol output, which would make use of your regular video card. I believe (but am not positive) that on a Dell XPS 13, that should be an Intel driver. It should, at any rate, show up as one of your DP*-devices, but is not.

Based on that, you might see if this answer from AskUbuntu is helpful. Another debugging steps you could take care:

  • See whether it works in Windows; if it doesn't, it's perhaps not supported at all.
  • Try booting up with the DisplayPort already connected, to see if it's a life detection issue.

You could also try using a DisplayLink cable, which would have different drivers. In general when you Google this, if I were you, I'd search for Ubuntu (on which Elementary is based) and "DP Alt Mode", which is what your cable uses.

  • Thank you for your relply, I'll try those steps later and update this post if I figure out how to solve this issue. – m0ntassar Jan 24 at 16:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.