2

If I enable capslock on my US keyboard layout Thinkpad X1 Carbon, the "v" key becomes inoperable; nothing happens when I press it until I disable capslock.

Here's the output of xev when capslock is disabled:

KeyPress event, serial 38, synthetic NO, window 0x5a00001,
    root 0x19f, subw 0x0, time 147956195, (90,106), root:(1281,753),
    state 0x0, keycode 55 (keysym 0x76, v), same_screen YES,
    XLookupString gives 1 bytes: (76) "v"
    XmbLookupString gives 1 bytes: (76) "v"
    XFilterEvent returns: False

KeyRelease event, serial 38, synthetic NO, window 0x5a00001,
    root 0x19f, subw 0x0, time 147956282, (90,106), root:(1281,753),
    state 0x0, keycode 55 (keysym 0x76, v), same_screen YES,
    XLookupString gives 1 bytes: (76) "v"
    XFilterEvent returns: False

Normal. With capslock enabled:

FocusOut event, serial 38, synthetic NO, window 0x5a00001,
    mode NotifyGrab, detail NotifyAncestor

FocusOut event, serial 38, synthetic NO, window 0x5a00001,
    mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 38, synthetic NO, window 0x5a00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 38, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

Notably, this happens only in X. If I drop out of X11 to a regular terminal (alt+shift+F2, or similar), "V" is normal with capslock enabled, so it's something weird happening in X11 or Pantheon.

1
+50

Looks like it's related to a keyboard shortcut associated with this combination. Go to System Settings -> Keyboard.

enter image description here

The tabs Layout and Shortcuts have all configurations for it.

enter image description here

Since I'm using WPS Office I had to install the IBus input method, that has also some configurable shortcuts. Check these out also if that's the case.

enter image description here

If this doesn't work, you can try dconf-editor:

  • sudo apt-get install dconf-editor
  • dconf-editor

    Make a search for "key" and you'll get a list of key bindings.

enter image description here

  • Thanks, Erick. Unfortunately, I'm not seeing any evidence that there's a keybinding to V. Why would it bind only when the caps lock is on, but not to shift+v? – Ken Kinder Jan 29 at 1:09
  • Blowing away my ~/.config directory did it, so it must have been something related to configuration; but I'm not sure what it was. Anyway, I'll add this as answered since it might have been related? – Ken Kinder Jan 29 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.