0

I have 2018 laptop with i5-8300h and Elementary OS 5. It doesn't suspend on lid close. However if I press button on the screen it suspends normally. I have tried to configure logind.conf but nothing changed. I also read a lot of different answers with the same questions, but nothing has helped.

  • Can you add details of what laptop you specifically have? You might also run sudo less /var/log/lightdm/lightdm.log to see whether there are any log entries related to what lightdm is thinking when it chooses not to suspend your laptop. – Ken Kinder Jan 22 at 16:59
2

More people seem to have the same issue: https://github.com/elementary/switchboard-plug-power/issues/94


For people interesting in how to switch settings via console:

It might be related to an issue in the switchboard app of elementary: https://github.com/elementary/switchboard-plug-power/issues/89

A workaround is explained here: Elementary OS ignoring suspend disable

In your case:

sudo su
su - -s /bin/bash lightdm

#check the values
gsettings get org.gnome.settings-daemon.plugins.power lid-close-ac-action

gsettings get org.gnome.settings-daemon.plugins.power lid-close-battery-action

#set values eg. to suspend
dbus-launch gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action suspend

dbus-launch gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action suspend
  • Thanks for the reply. But, unfortunately, both commands ( on ac and on battery) show 'suspend' – Secret-guy Jan 22 at 14:21
  • Sorry I couldn't be of much help :-/ At least you know that the settings are correct... I found this on github: github.com/elementary/switchboard-plug-power/issues/94 You can give a thumb up to show that you are also effected. Maybe you can give some helpful input there! – wirebug Jan 22 at 14:31
  • Do you have an external monitor attached during lid closed? Than you might have to set lid-close-suspend-with-external-monitor on true... – wirebug Jan 22 at 14:39
  • Thanks for help!) I don't use any external monitors. – Secret-guy Jan 22 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.