0

I've been trying to improve the sound in elementary Loki OS by following this tutorial https://medium.com/@gamunu/enable-high-quality-audio-on-linux-6f16f3fe7e1f but I cant seem to complete the last step as I'm unable to locate the asound.conf file. Any help would be be great. thanks

"Finally you have to configure the alsa to get the best audio output:"

$ vim /etc/asound.conf

The default configuration will be something similar to following:

Use PulseAudio by default

pcm.!default {
type pulse
fallback "sysdefault"
hint {
show on
description "Default ALSA Output (currently PulseAudio Sound Server)"
}
}

Change it to this:

Use PulseAudio plugin hw

pcm.!default {
type plug
slave.pcm hw
}
0

Don't do that. From that same post:

slave.pcm hw plugin will communicates directly with ALSA kernel driver. It is a raw communication without any conversion thus giving you a low latency audio output.

That's creating a sound interface that doesn't use pulseaudio and gives you the direct alsa output/input. Not many apps support alsa so you will end up with a broken audio system and all of the other settings you've applied won't have any effect.

Unless you are a music producer trying to record a single the disadvantages outweigh the advantages. The default config is already optimized to have a good quality with a fair cpu usage and a normal latency that is more than enough for any other task.

So yeah. Don't do it.

Finally, answering your question. You need to create that file since it's not needed by default. You can also just create a .asoundrc file on your /home directory so that it doesn't mess with other users setup.

By the way, Juno is already out so you might wanna upgrade!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.