4

Specs:

  • Elementary OS 0.3.2 Freya 64-bit, Ubuntu 14.04
  • Thunderbird 60.2.1 (64-bit)

TLDR:

I'm trying to change the date format of Thunderbird from MM/dd/yyyy to dd/MM/yyyy. I found out that in order to do that, I'd have to change my OS' locale, which I did, but that didn't update the date format in TB.

Long Version:

I've been struggling now for probably three hours getting Thunderbird to show the correct date format (dd/MM/yyyy HH:mm) to no avail. From my googling I found out that TB uses the OS locale and that I can change this by going to System Settings > Language & Region. But that didn't work for me.

When I tried that, I first changed the Region to "Australia" (because there's not a "South Africa" option) and the Formats to "South Africa (English)", saw that the date preview was what I wanted, hit the Set Language button and then restarted my PC. After rebooting, I noticed nothing had changed. The date/time display on the system's menu bar still showed "Fri Jan 4 3:51 PM", even though the Language & Region preview showed that it would be changed to "Fri 04 Jan 2019 15:04", and the date format used in TB stayed exactly the same (MM/dd/yyyy). The only change I could pick up was in Intellij Idea (2017.2.4), where the date format changed from MM/dd/yyyy to yyyy/MM/dd (which is still not quite what I want, but preferable to what it was).

Next I went back to Language & Region, updated the Region to "United Kingdom", left the Formats option on "South Africa (English)" (preview still looking exactly how I want it to), this time hitting the Set System Language button before hitting the Set Language button again, restarted my PC again, and lo and behold: Nothing changed.

After that I found the release notes for TB 60.0 which claims:

An option under "Tools > Options, Advanced, General" now allows to select whether date/time display will follow the application locale (adjusted by operating system's format settings for that locale) or the locale selected in the operating system's regional settings. In other words, an US English Thunderbird can use, for example, German formats.

I tried out the only check box available under that settings tab, but that also made no difference.

The very last piece of advice which I thought could solve my problem came from this answer, which suggests a TB addon that'd supposedly solve my problem, but in my case the addon is too old for my version of TB. Now I don't know what to do anymore.

Question:

Can anyone please help me set up the correct date format for TB (and preferably for the rest of my system too).


UPDATE:

In light of @rolandw's answer, I investigated the locale settings via the terminal. When I first ran the locale command I thought that this is clearly where my problem lies because, aside from LANG and LANGUAGE, all the other properties were set to en_US.UTF-8. I then googled how to change these settings and found this guide which pointed out to me that my system's locale settings is also stored in /etc/default/locale. But then it gets strange (IMO). When I cated this file, it only showed about half the settings that the locale command showed, and all of them were already set to en_ZA.UTF-8. The guide also showed me that I can run update-locale LC_<PROPERTY>=<VALUE>.UTF-8, so I ran it, setting LC_COLLATE=en_ZA.UTF-8, because I saw this property when I ran locale but not when I cated /etc/default/locale. After that I ran locale again, which produced the exact same results. Then I restarted my PC, thinking that it needs a reboot to take effect. I ran locale again, but everything is still the same (including LC_COLLATE, which is set to en_US.UTF-8). However, now if I cat /etc/default/locale, LC_COLLATE=en_ZA.UTF8 shows up.

Below are screenshots I took of this journey. The first screenshot shows everything before the restart (locale, cat /etc/default/locale, update-locale LC_COLLATE=en_ZA.UTF8, locale), as well as my Language & Region settings. Note that I haven't even unlocked this window, just to show that the settings still are as I left them since originally asking this question.

Picture One

This second picture shows what I did after the restart (locale, cat /etc/default/locale). Notice how LC_COLLATE now shows up in /ect/default/locale, which was not the case on the first screen shot.

Picture Two

1

I have Thunderbird 60.2.1 working on Juno and I am using the date formats exactly as you request (I'm in the UK and am very definitely of the English English camp...). In System Settings > Language & Region I have "United Kingdom" as Region, "United Kingdom" as Formats. I have also clicked on the "Set System Language" button (requires unlocking the system settings).

In Thunderbird I have nothing which will let me override the formats.

I would advise checking your system language settings. In terminal, just enter "locale" and hit return and it will show you what the current settings actually are. If they don't look right then search online for "setlocale" and you will find no end of guides as how to get this right. Or, of course, try "man setlocale".

  • Hey, thanks for the tip. I tried it out and updated my question with the results. – PrintlnParams Jan 10 at 6:17
0

I do not have Thunderbird installed. However, I just tried to change date format to dd/mm/yyyy and I see it is changed now.
Please chose South Africa (as you want to) from drop down menu of Formats and leave Region to United States. After that set system language and reboot your system.

  • Cool, I'm not at work right now but I'll give it another shot on monday. Thanks! – PrintlnParams Jan 5 at 7:23
  • I gave it another shot. It's still not working. :( – PrintlnParams Jan 7 at 6:01
  • Sad, I have voted up this one for you. Let's see what others say. – Hasan Jan 7 at 20:56

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.