0

Complete Linux noob here. I'm learning things by having just having a go at things. I'm currently exploring customising the desktop and I'm trying to install Avant Window Navigator.

I've downloaded the file and have unpacked it and read the README - not that it made much sense.

`The following packages are required to build Awn from source. Note that in most distributions, you need both the library and development/header packages installed in order for the build process to work correctly.

  • GNU Make
  • libdesktop-agnostic [1]_
  • libwnck 2.22 or later
  • libX11
  • dbus-glib
  • xdamage
  • xcomposite
  • xrender
  • Python 2.5 or later
  • PyGTK 2.12 or later
  • pyxdg (also known as python-xdg)`

I don't really know what a package is, or a library or a development/header package - but decided to give it a try anyway.

I went to the directory in the terminal and did ./configure and got the following message at the end

configure: error: Could not link test program to Python. Maybe the main Python library has been installed in some non-standard library path. If so, pass it to configure, via the LDFLAGS environment variable. Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib" ============================================================================ ERROR! You probably have to install the development version of the Python package for your distribution. The exact name of this package varies among them.

It sounds like I need to install python, but when I tried sudo apt-get install python it says version 2.7.15 is already installed, and this is a recent enough version. So does this mean it is in a non standard library path? How would I find out?

And how do I check for all the other things in the required packages list?

Thanks

  • Haven't read all yet first wanted to know what was this program. Now I know and just wanted to know why you want to install this if you have plank in elementary. I'll keep reading your question now :P – Sebastian Dec 31 '18 at 22:22
1

After reading about the project I don't recommend you to install this. Is too old and hasn't been active for years.

If you still want to install it, I could hep you with your errors but probably you'll find plenty.


The development package of python in elementary/Ubuntu is python-dev

sudo apt install python-dev

For the other stuff let's start to get the essential

sudo apt install build-essential

Then what you need in the list

sudo apt install libwnck22 libwnck-dev libx11-6 libx11-dev libdbus-glib-1-2 libdbus-glib-1-dev libxdamage1 libxdamage-dev libxcomposite1 libxcomposite-dev libxrender1 libxrender-dev python-gtk2 python-gtk2-dev python-xdg

I let to you find out how to get libdesktop-agnostic installed, too old

ref: https://github.com/p12tic/awn

  • So it sounds like this won't work then. I'm sensing that old means no longer works. It looks like the icon pack I was interested in is no longer available anyway. What is plank? – Michael wx Jan 1 at 14:59
  • As I'm now not going to try this then do I have to undo anything when I did the ./configue ? – Michael wx Jan 1 at 15:47
  • configure just do stuff inside the working dir, even make is harmless.... make install is the one you run as root because it install the files in the system. Just deleting the directory is enough. – Sebastian Jan 1 at 16:25
  • Plank is the icon bar below - i.stack.imgur.com/Uwcag.png – Sebastian Jan 1 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.