Powered up this morning to be greeted with the GNU Grub screen version 2.02. I chose +Advanced options, then elementary, with Linux 4.15.0-43-generic (recovery mode). After a long list of command lines, it ended with

/dev/sda2: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. fsck exited with status code 4 done. Failure: File system check of the root filesystem failed.

This happened two weeks ago and the tech I took it to was stumped - never seen anything like it before. He found a third "hidden" partial partition. (I run a MacBook Pro mid-2012)

He couldn't save any of my files since I first switched to elementary OS. Lost a week's worth of converting and organizing files. Had to reinstall from thumb drive.

  • Is this something from in the first partition?
  • Is this a problem with the Libre Writer in the second partition?

elementary OS had been running clean and fast up until this point. This is unacceptable. Help!

1 Answer 1


First that "Tech Guy" didn't knew a thing or is lying to you if he never saw a message like that. You can even Google it and you'll find dozens of articles about this, even your exact same issue.

The message you saw was a notice from the system that an error on the disk was detected, so it wanted you to run a command manually RUN fsck MANUALLY

A fragment from fsck's manual

       fsck  is  used  to  check  and  optionally  repair  one  or more Linux filesystems.  filesys can be a device name (e.g.
       /dev/hdc1,  /dev/sdb2),  a  mount  point  (e.g.   /,  /usr,  /home),  or  an  ext2  label  or  UUID   specifier   (e.g.
       UUID=8868abf6-88c5-4a83-98b8-bfc24057f7bd or LABEL=root).  Normally, the fsck program will try to handle filesystems on
       different physical disk drives in parallel to reduce the total amount of time needed to check all of them.

       If no filesystems are specified on the command line, and the -A option is not specified, fsck will default to  checking
       filesystems in /etc/fstab serially.  This is equivalent to the -As options.

       The exit code returned by fsck is the sum of the following conditions:

              0      No errors
              1      Filesystem errors corrected
              2      System should be rebooted
              4      Filesystem errors left uncorrected
              8      Operational error
              16     Usage or syntax error
              32     Checking canceled by user request
              128    Shared-library error

Your exit code was 4, that meant Filesystem errors left uncorrected and was on /dev/sda2 partition

You may ask why that happen. Well could be multiple reasons. One of them was probably that the system did not shutdown normally

I have to tell you that probably you didn't lose anything, was your "tech guy" stupidity and ignorance that caused that. I can't confirm this 100% because you never tried to fix the disk with the tools in hand.

And about the hidden partition, a "tech guy" should know that in a GPT layout installation you will have a hidden partition used for recovery. Is part of the standard and doesn't have any ties with the system you choose to install. Probably that was that "mysterious hidden partition".

You can see that this could happen also on Mac OS, almost identically because it's ties with Unix (same command fsck)



Follow what it says

  • Run fsck /dev/sda2 (Say yes to everything) or run fsck -fy /dev/sda2 (forcing and saying yes to all automatically)
  • Reboot

If the problem persists after you run fsck, that could mean other things, but always go one step at a time.

What you meant with "Crapple kernel"?

  • Thank you for the information. Linux is new to me. (The last time I programmed was in Assembly on a PDP1145 with punch cards.)
    – Steve L
    Commented Jan 8, 2019 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.