-1

I am pretty new to Linux so thought I would get a small laptop for Christmas to learn on. I now have a new Lenovo Ideapad 130S, which seems like an ideal machine, and I downloaded Elementary OS as it looks great.

But having installed it I now find that the touchpad is freezing randomly, which is a bit of a pain. I can unfreeze it by locking the OS with the power button and logging back in again, but it will always freeze at some random point. I have also tried using the touchpad lock button, which works normally but won't unfreeze it when it is locked.

It works fine with Windows, so I know it's not a hardware fault, but it freezes on every other distro of Linux I've tried too (Fedora, Mint, Ubuntu...). It does seem to do it less often with Elementary though. I can't see any BIOS settings that would amend this.

Can you help? Many thanks.

  • Does your system recognize your touch pad? What do you see when you execute xinput in your terminal. – Hasan Dec 27 '18 at 14:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.