I have a weird issue. I installed elementary OS Freya last night. Long story short, I got tired of the issues I had with Windows 10 upgrade and decided to take the plunge. When I installed elementary OS, I chose to encrypt my hard drive as I use this laptop for work. Everything went great until I plugged in my second hard drive and tried to boot. I use a SSD drive for my main operating drive and a platter drive for storage. When I try to boot with both hard drives plugged in, after bios splash screen, the screen just goes to black. no logo, no encryption login, nothing. I left it for almost an hour last night just thinking it may work itself through it, but nothing. as soon as I unplugged the secondary sata drive and did a hard reset, it booted right up no problem.

If I plug in the drive while elementary OS is running, it shows right up and I have full access. I can do this short term, but in the long run, I cannot keep this up when I have a perfectly serviceable bay to keep the drive in.

Thanks for your help and let me know any info you may need!!

  • That would probably be happening because of the boot loader is confused which one of those two drives have the OS installed. Unfortunately, by default it reads the hard drive that you plugged in later. Try Changing the Boot Order in Boot Loader. That should fix it for you.
    – devGeek
    Commented Sep 3, 2015 at 18:34
  • @devGeek, thanks for the suggestion. I just rebooted to confirm, and I had moved the secondary drive all the way to the last position. I was thinking it probably had more to do with the primary drive being encrypted and the secondary is not. I am lost though beyond that!
    – Steve
    Commented Sep 3, 2015 at 23:10
  • did that worked?
    – devGeek
    Commented Sep 7, 2015 at 20:09

1 Answer 1


The machine is attempting to book to your second drive. There are a few things that fix this:

Reorder Boot Devices in BIOS

By pressing the function keys, ususally F2 during startup (like, as soon as you power on), you can enter the BIOS. Look for a "Boot Order" section of the BIOS (usually one of the last tabs). Find your USB HDD, USB DISK, and/or your USB CD and move it/all three to the bottom of the list, so that your main disk (either SATA or IDE) is on top.

Remove "BOOT" Flag from the Drive

Usually when OS's are installed on a drive, they manually flag the drive as bootable with the BOOT flag. This is good, until you delete the OS. For many other reasons, your drive might have a BOOT flag on it.

Start up your and plug the drive in after it has booted.

Install gparted: sudo apt-get install gparted

Run gparted: sudo gparted

Look for you naughty disk on the upper-right corner of the screen (using a flashdrive for this example): GParted Drive Selection

Select it, right-click the partition that says "boot" on the right side, and uncheck the "boot" flag:

enter image description here

Once unchecked, close the flag window and close GParted.

If you still have trouble, let me know how it goes and I'll see if I can help more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.