6

After sometime of my desktop being suspended, if I wake up the machine, bluetooth is turned off. I need to plug a usb mouse to reenable bluetooth via the indicator and then I can use my devices as intended.

I already have enabled and uncommented AutoEnable under Policy on /etc/bluetooth/main.conf

Any ideas on why or how can I fix this

  • Which version of elementary are you using? – Sebastian Jan 1 '19 at 18:27
  • I had the same issue, but it stopped happening after I upgraded all my packages and rebooted recently. – Ken Kinder Jan 31 '19 at 18:06
1

This solution worked for me so far:

Edit /etc/bluetooth/input.conf and under section [General], uncomment the line IdleTimeout=0

# Set idle timeout (in minutes) before the connection will
# be disconnect (defaults to 0 for no timeout)
IdleTimeout=0

Interesting that defaults to 0... but in my computer bluetooth was disconnected after roughly 10 minutes.

After specifically defining "0", I tested with more than 1 hour inactivity. Also, I switched the USB adaptor from a regular USB port to a USB 2.0 port (it didn't fix the problem before, but since I enabled the IdleTimeout, it's working now).

Hope it helps you too...

| improve this answer | |
0

Allright, so I found this on the internet. I cannot test this on my own so I can't confirm it as a working solution but it seems to coincide with your issue. You could give it a try.

Fixing Bluetooth in Ubuntu, Pop!_OS 18.04

| improve this answer | |
  • Already tried those :/ with no avail. Thanks for the reply :D – Carlos Flores Dec 31 '18 at 22:02
  • 1
    I am so sorry, I hope someone with more knowledge will be able to post a solution, this issue with the usb port has been going on since always on linux systems, such a shame. – user16597 Jan 1 '19 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.