I just made the switch from Windows, I previously had elementary OS running on an old MacBook with no problem but this computer died. I now have a Razer Blade Stealth 12.5" 4k from late 2016. I performed a fresh install of elementary OS 5.0 and was able to go through the whole install and login screen no problem. I also selected the option to format the whole disk. Right after I login I get this screen and cannot do anything.

Razer Blade Stealth screen issue

During the installation process I also selected to install updates during the install as well as drivers. If someone has an idea please let me know I really want to run elementary OS as my main OS.

Thank you so much!


1 Answer 1


Restart your laptop and press e when grub appears. Then add intel_idle.max_cstate=4 between quiet splash and press F10 to continue.

If that worked you need to make it permanent. Open a terminal and type:

sudo io.elementary.code  /etc/default/grub

You'll see a line similar to this:


then edit the line and leave it like this:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash button.lid_init_state=open intel_idle.max_cstate=4"

Now you can close that window. Then execute sudo update-grub and reboot to see if it works.


  • Ok that was really close and since I'm a super noob I had to lookup every step in details haha. But I did a fresh install, added intel_idle.max_cstate=4 as suggested and it worked, so I went into the terminal and did add the line right after the quiet splash line. It worked ok for a little while but now a few seconds after logging in I get the same screen again. Also my booting screen changed a little bit instead of the Elementary logo I just have something looking like a verbose boot I guess? I can show you if necessary. You made me the happiest person for like 20min!! :D
    – Frog
    Dec 18, 2018 at 14:00
  • So in case it is needed here is my boot screen before I enter my password to decrypt i.gyazo.com/3be07c00703c7d1066304e070214ee64.jpg and this is the grub settings (after adding the parameters via the terminal as you suggested) i.gyazo.com/f2c666ced7fa8642f7e641f796db663a.jpg
    – Frog
    Dec 18, 2018 at 14:40
  • I've updated my question to be a bit more clear. Hope you understand now :) When you boot you just need to enter the intel_idle.max_cstate=4 part the first time! When you edit the file called /etc/default/grub then it's done, you don't need to do it again!
    – Maccer
    Dec 18, 2018 at 18:57
  • Haha thanks @Maccer ! So the screenshot I showed you are all after I edited the grub file I did not enter intel_idle.max_cstate=4 again after that, I just entered the grub to show that it apparently saved it correctly. So I did another clean install just in case to try again with your instructions. One last clarification if you don't mind I'm paranoid now, when you say between quiet splash you mean 1, 2 or 3? i.gyazo.com/thumb/1000/19776665296309848b58be20e3a9876f-jpg.jpg like literally between the words, at the end of the line or between the lines? :D
    – Frog
    Dec 18, 2018 at 21:48
  • 1 or 3 should work
    – Maccer
    Dec 19, 2018 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.