0

I have an SSD with Windows 10 on it, a HDD to go along with it with just data, and now an SSD with elementary OS on it. During the installation i had some problems, so unplugged the SSD of Windows 10, and HDD's SATA cables, and the installation ended up correct. Now if I start the PC I don't get the GRUB screen, but the elementary OS login screen instead. I tried to edit the grub config, and update it manually, but that did not help. How could i manage the dual boot?

0

I tried to edit the grub config

We don't know what you did configuring grub so maybe you did the following


By default Grub comes hidden

to change that just edit

$ nano /etc/default/grub

Change where it says

GRUB_TIMEOUT_STYLE=hidden

,to

GRUB_TIMEOUT_STYLE=menu

Now update grub

$ sudo update-grub

Reboot to test

You can adjust the timeout in seconds there too.... check the manual

https://www.gnu.org/software/grub/manual/grub/html_node/Simple-configuration.html


Also there's a way to access the Grub menu without editing

Just after the Bios/UEFI post, press SHIFT repeatedly. If you fail the timing, reboot and try again.

0

Try running boot-repair from the USB installation media, this has worked for various problems for me in the past: https://launchpad.net/~yannubuntu/+archive/ubuntu/boot-repair.

sudo apt install software-properties-common
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt update
sudo apt install boot-repair

This should automatically detect your Windows 10 partitions.

  • Unfortunatelly it did not solve the issue, after a reboot it prompted me for the encryption key again, instead of the GRUB menu. Does this mean i have to do a clean reinstall? – Daniel Dec 16 '18 at 22:00
  • @Daniel may as well, if you haven't customised too much. But this time perhaps note exactly what problems you get with the SSD plugged in and edit your question. – trishmapow Dec 16 '18 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.