0

In order to keep this post short, allow me to point you to a rather old Scribus bug report, which perfectly describes the problem. This specific bug has been fixed upstream, and is not present in Ubuntu 18.04.1, or Xubuntu 18.04.1, or Linux Mint 19. BUT, it is present in elementaryOS 5.0 which is very strange. It would be nice if someone provided some solution since it cripples an otherwise perfectly working package:

https://bugs.launchpad.net/ubuntu/+source/scribus/+bug/177805

Kind Regards

1

FYI, the Scribus that comes with comes from Ubuntu

$ apt policy scribus
scribus:
  Instalados: (ninguno)
  Candidato:  1.4.6+dfsg-4build1
  Tabla de versión:
     1.4.6+dfsg-4build1 500
        500 http://cl.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

About the Question

Remove Scribus

sudo apt purge scribus

Install flatpak

sudo apt install flatpak

Add flathub repo to flatpak

sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Install Scribus (a newer version - current Scribus 1.5.4)

sudo flatpak install flathub net.scribus.Scribus

What is flatpak?

https://flatpak.org/faq/


ref:

https://flathub.org/apps/details/net.scribus.Scribus

https://flatpak.org/setup/Ubuntu/

1

You can just add Scribus PPA with:

sudo add-apt-repository ppa:scribus/ppa

and after

sudo apt update && sudo apt dist-upgrade

, you'll have 1.4.7 version.

If you like you can install scibus-ng (version 1.5.4) from the same PPA.

sudo apt  install scibus-ng

Note

If you get an error like "command not found" after using add-apt-repository. Just install software-properties-common and run again the previous command:

sudo apt  install software-properties-common

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.