-1

I am clueless how to open blend files from the file manager. It doesnt show up in default applications. Can you tell me how to set blender as default program for .blend files? Thanks! Andreas

1
  • I can't reproduce your problem I just installed Blender (sudo apt install blender). Opened it. Saved the file as test.blend on $HOME. Closed Blender. Opened pantheon-files and clicked on the file test.blend. Blender opened the file.
    – Sebastian
    Dec 13 '18 at 11:12
1

You didn't mention how you installed Blender, but I guess you downloaded the official build from the website as a tar.bz2 and extracted that somewhere. If you download from AppCenter it should work out of the box, but you will probably not get the most current version.

If you installed it manually, in order for Blender to show up in the desktop environment you need to provide a .desktop file. That will put it in the application launcher in the top bar and it will also let you open .blend files from the file manager.

The official Blender download comes with a desktop file, but you will have to edit the line that says

Exec=blender %f

to something like

Exec=/path/to/blender %f

... where of course you should substitute /path/to/blender with the real path.

Then copy or link the file to ~/.local/share/applications/.

1

In Files, right click on the .blend file and select "Properties". A small options window will appear and at the bottom there will be an "Open with" dropdown, and in it is an option to select another application. From here you can select Blender and set it as default.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.