0

I have installed Juno on a thinkpad t480 (no dual boot, i7, 8th gen) and it worked flawessly until i pulled the usb-c (with 2 ext monitors, ethernet) out. The screen went black and booting takes me past the logo into a loop where the black screen yields a single underscore dash prompt in the very top left corner for about a second before disappearing again for another second. It just loops from there. I have tried ctrl+alt+f1 and it shows text mode for about half a second with no option/chance of logging in via tty. Secure boot is disabled. There's no clear instructions anywhere on how or what to do in the grub interface (2.02). Is it the boot sequence or the actual kernel that's corrupt? Is there a way to repair my installation from the usb installer? How can I prevent this form happening again? I really would like to stay in Juno and not go back to regular Ubuntu. What am I missing? Any help is appreciated, thanks!

1

You could try this, it works for ubuntu so might work for Eos

At the login screen, press CTRL+ALT+F1 to switch to tty1.

Now, type the following commands one by one to fix the broken Ubuntu Linux.

$ sudo rm /var/lib/apt/lists/lock

$ sudo rm /var/lib/dpkg/lock

$ sudo rm /var/lib/dpkg/lock-frontend

$ sudo dpkg --configure -a

$ sudo apt clean

$ sudo apt update --fix-missing

$ sudo apt install -f

$ sudo dpkg --configure -a

$ sudo apt upgrade

$ sudo apt dist-upgrade

Finally, reboot the system using command:

$ sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.