0

I'm having trouble with my audio drivers after I switched from a Dell XPS 8500 to a custom build with a Ryzen 5 2600X for my processor, Gigabyte Aorus Gaming 5 Wifi x470 for my motherboard, and a Sapphire Radeon RX 580 video card. I used the same hard drive as before, so I didn't reinstall eOS.

The sound card for the mobo is an Intel ALC-1220-VB. I have tried force reloading and re-installing ALSA using the following commands:

sudo alsa force-reload

then

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload

Additionally,

lspci | grep -i audio

Does recognize 2 audio cards. The first one appears to the audio card on the video card, the latter should be the mobo's audio card right?

09:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 580]
0b:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller

I've searched on Google a fair bit and tried a bunch of other things but I can't find those pages anymore and none of them worked. How do I resolve this issue?

Thanks in advance!

UPDATE

New wrinkle: GNOME Alsa Mixer identified a USB audio device. Curious, I tried plugging my speakers into the front panel of my PC. That headphone jack is working. The AC1220 still produces no signal.

UPDATE 2

So I think I figured something out. I don't know how to fix this but it seems to be a diagnosis.

lspci | grep -i audio

Returns 2 audio cards, but these are my video card and the front panel headphone jack. The following

lspci | grep -i 1220
lspci | grep -i ALC1220
lspci | grep -i realtek

Return nothing.

aplay -l

Does recognize ALC1220 as

card 2: Generic [HD-Audio Generic], device 0: ALC1220 Analog [ALC1220 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Generic [HD-Audio Generic], device 1: ALC1220 Digital [ALC1220 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Does this identify the issue?

0

search in appcenter. GNOME ALSA Mixer. verify that it is not muted. It seems ridiculous, but try it, it worked for me.

please let us know if it works for you.

cya.

  • I downloaded GNOME ALSA Mixer and unmuted everything and fiddled with it, still no sound but it did show me that the sound card is made by Realtek so I'm going to check google to see if that piece of information helps me find a solution. Thanks – P. Harmon Dec 6 '18 at 0:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.