0

This question already has an answer here:

I have a Compaq 21N121AR Laptop and this is my problem: After I make a mouse movement and my finger leaves the mouse touchpad, my touchpad goes in a kind of "Sleep Mode" and it takes a few "swipes" to move again. I used the xinput list command and noticed that one of the devices dissapears (I assume it's the mouse touchpad). This is before I move my mouse, note the virtual core pointer part:

xinput list screenshot

This is while moving the pointer: enter image description here

marked as duplicate by Hasan May 3 at 19:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Found it! It seems to be a problem with the libinput drivers, I solved my problem removing them and installing the synaptic drivers instead

sudo apt-get remove xserver-xorg-input-libinput libinput-tools

this removes libinput drivers, and then to install synaptic drivers:

sudo apt-get install xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics

And then I restarted the system and it was solved. Thanks to Jason Gambrel for posting this solution on Trackpad randomly freezes

Not the answer you're looking for? Browse other questions tagged or ask your own question.