0

Elemantary OS Touchpad is not working on Lenovo Ideapad 330s.

I tried libinput and synaptics installation an configuration but it did not work.

3
  • Are you getting any error messages when installing libinput and synaptics?
    – Paul
    Nov 29 '18 at 18:38
  • can you elaborate on what you did and installed when you said "I tried libinput and synaptics installation"
    – Sebastian
    Dec 1 '18 at 0:20
  • I found anything helpful but before I just saw a post saying downgrade or upgrade the kernel will work but I just lost the link.
    – Bugs BUNNY
    Jan 18 '20 at 6:50
0

Did you tried this?

sudo apt install xserver-xorg-input-synaptics

ref: https://askubuntu.com/questions/1031940/how-to-switch-from-libinput-to-synaptics-in-ubuntu-18-04


Also you could check the part where you should check if you have two touchpads in the following link:

https://www.dell.com/support/article/cl/en/clbsdt1/sln308258/precision-xps-ubuntu-general-touchpad-mouse-issue-fix?lang=en

0

Don't know if this will help, but have you tried to change the touchpad to basic in the bios. this worked for me on a different os.

0

I have an IdeaPad S145 and I think it's possible that the touchpad be the same. This post worked for me.

https://askubuntu.com/questions/1227972/touchpad-of-lenovo-ideapad-s145-15iil-not-detected-in-18-04-and-19-10-ubuntu-an

The workaround is to pass these parameters to the kernel.

i8042.nopnp=1 pci=nocrs

It's recommended to test before change definitely like this.

https://wiki.ubuntu.com/Kernel/KernelBootParameters

Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.