I have one of my keys mapped to XF86Refresh which I confirmed with xev. In Firefox and Epiphany pressing the key works as expected, but in Chrome it acts like CTRL + F. Here's what xev says:

KeyPress event, serial 38, synthetic NO, window 0x3c00001,
root 0x173, subw 0x3c00002, time 6983238, (27,11), root:(898,478),
state 0x0, keycode 69 (keysym 0x1008ff29, XF86Refresh), same_screen YES,
XLookupString gives 0 bytes: 
XmbLookupString gives 0 bytes: 
XFilterEvent returns: False

Video showing issue

2 Answers 2


First... I don't know how to map keys, never needed it. You should write the next time detailed info of what you did.


Why you use XF86Refresh?

I've read that is better to use XF86Reload instead

You should try and test if that helps you, looks like it was a consolidation a while ago

  • Editing keymappings is a necessary hoop to jump through for us folks on chromebooks with non-standard keyboards. The short version is you edit /usr/share/X11/xkb/symbols/pc. If you want to see exactly what I did, I forked a repo and edited the script for my purposes on my github. As far as why use XF86Refresh, it worked fine a few weeks ago and works as expected in any other browser besides Chrome, so I don't know what the issue is, but I'll give XF86Reload a try and see if that works! Commented Nov 27, 2018 at 22:40
  • Is this the keyboard? i.imgur.com/gtjfR0U.jpg , and the key is the "refresh" next to the "right arrow" on the top-left? I didn't knew they had different keyboards, never tried to see them in detail because wasn't interested in them :P
    – Sebastian
    Commented Nov 27, 2018 at 22:46
  • Yup, and that's the key I'm fiddling with. If you're willing to tinker, they can make excellent linux machines, and for a lot cheaper than regular laptops. Commented Nov 27, 2018 at 22:58

Following what @Sebastian suggested, I remapped the key in question to XF86Reload. Reloading a page in Chrome works fine now, and still works in Epiphany, but broke in Firefox. Since I don't use Firefox too much, and since CTRL + R still works fine, this solution is workable for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.