0

I had elementary OS and Windows 7 installed. In Windows 7 i deleted the elementary OS Partition. After rebooting i got this:

error: file not found.
grub rescue>

So I searched the internet and wise Internet suggested putting the Windows DVD in the computer and click repair and type something in cmd.exe. Problem: When I click on "Repair your PC" a message says that the DVD and the Windows Version are not compatible. But it is the Same DVD I installed Windows earlier and I didn't do any updates!

Ok so next try: Installing Ubuntu again. I did it using a bootable USB Stick and successfully installed Ubuntu. I thought that GRUB would be restored after I reinstall Ubuntu. But false! Still the same message. Then in grub rescue I tried ls:

(hd0)(hd0,msdos5) (hd0,msdos4) (hd0,msdos2) (hd0,msdos1) (hd1)

(hd1) is the bootable USB Stick.

Then I tried searching for the /boot/grub folder on every drive. Every drive got me this: error: unknown filesystem. except for (hd0,msdos5) which gave me error: bad filename.

I am really confused, really don't know what to do and I don't want to lose my data on the Windows Partition! Can anyone help me?

  • Have you tried: help.ubuntu.com/community/Boot-Repair? I'm not quite sure if you will need a small linux installation to keep the fix working, but it should automaticly locate your windows partition and list it as a boot option in grub. Your done goofed up when you just formated the linux partion on wich the configuration for grub was located I would guess. So that when grub starts on boot from your MBR (not 100 sure here either.) it has no config file to look up. If I where you, I would boot into a live-CD, get NTFS(-3g) compatability and copy your data to a USB then reinstall Win. – Kultom Sep 2 '15 at 10:27
  • Comment got to long, but here is how to enable ntfs-3g in ubuntu, should be similar even though this guide is old: howtoforge.com/ntfs_3g_ubuntu_feisty – Kultom Sep 2 '15 at 10:29
  • Thats just what I want to do too but I have 190 GB of Data and maby 40gb of USB Sticks – Sérgio Ferreira Sep 2 '15 at 10:29
  • When I Installed Ubunutu it didnt show "Installiert Ubuntu besides Windows" so I guess Boot Repair would be pointless. Although When running ubuntu from the Live Stick The Windows Partition is accesable – Sérgio Ferreira Sep 2 '15 at 10:31
  • Then maybe this? howtogeek.com/howto/32523/… Im just googling at this point. Hopefully youll get a good solution from someone else who might have had the same problem once. – Kultom Sep 2 '15 at 11:00
2

I had the same problem once I got rid of Ubuntu from my laptop which had dual boot. The problem is caused because grub is also removed along with the Linux distribution preventing you from booting to either Windows or your Linux distribution.

If all you want to do is to boot to Windows directly, you could do the following:

  • insert Windows CD
  • go to recovery mode
  • open command prompt
  • type the following commands:

    Bootrec /fixmbr Bootrec /fixboot

You should be able to boot directly to Windows after this.

  • In the first post I said that this is impossible – Sérgio Ferreira Sep 2 '15 at 18:45
  • Did you try a different image/DVD of Windows? – shyam Sep 2 '15 at 18:50
  • I fixed the Problem with backing up everything and formating the HDD and installing Windows again – Sérgio Ferreira Sep 2 '15 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.