1

I'm trying to install elementary-tweaks on Juno but adding the ppa is causing an error. Here is my console output...

Err:7 http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu bionic InRelease                                                                  
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C1D89326B1C71AB9
Get:10 http://packages.elementary.io/appcenter bionic/main amd64 DEP-11 Metadata [88.5 kB]
Hit:11 https://packages.lunarg.com/vulkan/1.1.85 bionic InRelease 
Reading package lists... Done                                           
W: GPG error: http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C1D89326B1C71AB9
E: The repository 'http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Anyone know how I go about fixing this ? Thank you.

  • I had the same problem. @Sebastian's answer resolved the issue for me 👍️ 👍️ – Armaan Ali May 16 at 19:04
3

Follow this steps

Open a terminal, then write and execute (by pressing ENTER) this commands, one at a time:

  • sudo apt install software-properties-common

    • will ask your password
  • sudo add-apt-repository ppa:philip.scott/elementary-tweaks

    • will ask you press ENTER to confirm the installation of the PPA

    • (newer version of add-apt-repository runs apt update after automatically. In case it didn't, just run sudo apt update yourself)

  • sudo apt install elementary-tweaks


Description of your problem:

You didn't (don't) have the gpg key, with add-apt-repository you get it. And installing software-properties-common provides that command.


I'm curious, which instructions did you follow to install elementary-tweaks?

  • Hi. Well I'm sure I used those same command lines cribbed from another post. When I added the ppa there was a long delay and then an error was output, which I didn't grab unfortunately. Going through those three lines again has worked, thank you. – Martin Linklater Nov 26 '18 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.