1

When i watch videos on youtube using firefox or Epiphany the video freezes when i do nothing for a few minutes and i have to move the mouse so that the video continues it's a very annoying problem if you know the solution your answer is appreciated.

I think this person is having the same problem video freezing when do nothing for a few minutes

and this person Videos in Epiphany problem this person is using loki so this problem is in loki and juno as far as i know.

2

I had the same issues on two different computers, one with Intel HD4400 and one with Intel HD620 CPU/GPU. This is how I resolve the problem:

  1. Install Updated Open Graphics Drivers PPA

    sudo add-apt-repository ppa:oibaf/graphics-drivers

    sudo apt update

This will update your Mesa graphics drivers but most importantly your xserver-xorg-video-* driver. A note of caution: It's been known for these drivers to have some issues so I would suggest that after the update, if everything works, remove this PPA from your sources list.

  1. Create /etc/X11/xorg.conf.d/20-intel.conf file with this content:

    Section "Device"

    Identifier  "Intel Graphics"
    
    Driver      "intel"
    
    Option      "AccelMethod"    "sna"
    
    Option      "DRI"            "3"
    
    Option      "TearFree"       "true"
    
    Option      "Backlight"      "intel_backlight"
    

    EndSection

  2. Install mpv Media Player. Not gnome-mpv but mpv. Use this for playing your local videos.

The 1. and 2. did manage to remove all my video-in-browser troubles, I even get to have hardware acceleration in Google Chrome without any issues. Number 3. helped me with the local video files.

There is a good reading on this here: IntelQuickSyncVideo


In case you don't have the command add-apt-repository

Run:

sudo apt install software-properties-common

and then redo the previous command who contains add-apt-repository

  • Please note that that intel.conf can cause issues. See the relevant open issue: github.com/elementary/os/issues/121 – Peter Uithoven Nov 30 '18 at 14:48
  • this solution increased CPU load unfortunately. we need more efficient fix – pole Dec 2 '18 at 2:42
  • 1
    @pole I mentioned in my post that this is something that helped me on two different configurations, not to be a universal fix. The CPU load while playing 4K video on a laptop is around 20% and on my PC below 15%. Thank you very much for lowering my reputation, you are the man. – WebShaped.Biz Dec 2 '18 at 9:18
  • Instead of removing the PPA after the installation (which leaves the installed packages without a corresponding repository) you could also "hold" the packages or use apt pinning. See the Ubuntu Community Wiki for an intro with examples: help.ubuntu.com/community/PinningHowto – Michael Kanis Dec 18 '18 at 10:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.