1

When using io.elementary.videos, cinema (from the store), or totem (from gnome) (gui)applications, after a while, the video stops while the audio continue his execution.

I used .mp4 and .mkv videos and codec gstreamer.

My pc is a Dell inspiron 7559 (laptop) with Quad-Core Intel® Core™ i7-6700HQ CPU @ 2.60GHz, Intel Corporation HD Graphics 530 and NVIDIA Corporation GM107M [GeForce GTX 960M] (with propietary drivers).

It has a 4k screen.

Someone knows how to fix it?

Thanks

  • without detailed information... there's nothing to answer. If you want an answer based on your question, I should say just stop watching videos. – Sebastian Nov 26 '18 at 1:58
  • 3
    maybe is more helpful to say what kind of information do you need, isn't it? – user16488 Nov 26 '18 at 8:49
  • I have the same issue and it's pretty much generic. Anything (video) i start playing just lags. I have a intel video card. Works perfectly with many other Linux distros, including Ubuntu, but not Elementary. Sebastian... be nice. – Telmo Nov 26 '18 at 14:35
  • This isn't a place to be nice, just to answer questions. And a poor question deserves that kind of answer. What kind of information? Which program did you use? which video? which codec? did you use the command line or directly through the gui? are you comfortable using the command line? you video card information? if it's a laptop, which brand and model? did you installed a third party driver?... etc. Quoting: "Be specific If you ask a vague question, you’ll get a vague answer. But if you give us details and context, we can provide a useful answer." – Sebastian Nov 26 '18 at 15:08
  • 1
    Sebastian, yes it is a place to be nice. According to the Code of Conduct: "Be kind and friendly. ", and "If you’re here to help others, be patient and welcoming." – Paul Nov 26 '18 at 15:54
1

First

Let's check if you have Nvidia drivers installed

Install:

$ sudo apt install software-properties-gtk software-properties-common

Open:

$ software-properties-gtk

Choose the tab Additional Drivers

Wait for the loading list, and then you should see the installed drivers.

enter image description here

If you don't see any NVIDIA proprietary driver in the list, you need to install them

If you see them, just choose it and then reboot to start clean


To install the driver

Use the command:

$ sudo ubuntu-drivers list

You should get something like this (probably different version numbers):

nvidia-304
nvidia-340
intel-microcode
nvidia-367

Install nvidia-367 (or the version you want/need, and could be different)

$ sudo apt install nvidia-367 nvidia-settings

Then and again you have to choose the driver

Open:

$ software-properties-gtk

Choose the tab Additional Drivers

Wait for the loading list, and then you should see the installed drivers.

enter image description here

Just choose the driver in the list and then reboot to start clean

ref: https://gist.github.com/Jiab77/d3344422ee6d334f284425b558dc572c

Now, after reboot, open $ nvidia-settings

Look after an entry named PRIME Profiles, select it and then choose the NVIDIA GPU

enter image description here

Reboot again

Now try open a video

Use mpv (If you don't have it install it with sudo apt install mpv)

Play the video with the command:

mpv -v filename.mp4 (or mkv,avi, etc)

In case the error continues, just copy and paste the text in the terminal. It will be a lot because of the -v flag.


Additional Info

You can also check and change PRIME using a command

Install:

$ sudo apt install nvidia-prime

To check

$ sudo prime-select query

To select Intel GPU as PRIME

$ sudo prime-select intel

To select NVIDIA GPU as PRIME

$ sudo prime-select nvidia

ref: https://www.linuxbabe.com/desktop-linux/switch-intel-nvidia-graphics-card-ubuntu


Also for future reference in case the answer doesn't work

Run

sudo lshw -sanitize -class system,processor,display,multimedia

copy the output and paste it here editing your own post

  • with mpv only the video works without the need of the nvidia card. – user16488 Nov 27 '18 at 20:30
  • check this...the same issue than you and a NVIDIA card without the drivers installed/updated elementaryos.stackexchange.com/a/15046/14940. If you want to resolve te issue follow the steps, If not then just use mpv – Sebastian Nov 27 '18 at 22:06
  • I already installed Nvidia driver (but i selected intel with prime to save battery), and I had already installed both ffmpeg and all the gstreamer packages. But the problem is still there...maybe I should report it as a bug – user16488 Nov 27 '18 at 22:12
  • Without a proper log from you and only taking your word of what is happening, yes you should report it as a bug. github.com/elementary/videos/issues gitlab.gnome.org/GNOME/totem . At least you can play videos through mpv (fyi my main video player) – Sebastian Nov 27 '18 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy