2

I want to try either no top panel or maybe something else. I assume I can do this by putting a .desktop in an autostart directory, but how to stop Wingpanel loading at start?

  • Is this for Juno? – Paul Nov 27 '18 at 7:57
1

For Juno:

1) Install dconf-editor

2) Run dconf-editor and go to /io/elementary/desktop/cerbere/monitored-processes

3) Uncheck "Use default value"

4) Remove 'Wingpanel' in Custom Value

5) Log out and then log back in.

If you do this, I highly recommend adding the application menu to Plank:

1) Hold Ctrl and alternate-click anywhere on the Plank.

2) Select Preferences.

3) Click the Docklets tab.

4) Double-click Applications

Now you can access your applications without the Wingpanel.

To have wingpanel start automatically again, either select "Use default value" or put 'wingpanel' back into the Custom Value in dconf-editor.

To start wingpanel manually, open a terminal and type wingpanel.

Here's what the edited dconf window should look like:

enter image description here

Here's what my desktop looks like without the Wingpanel. It also has the Application Menu on the Plank.

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.