I need this program for my work and I installed it with gdebi. I can see the icon but I can't get it to start. The icon goes up and down when I click on it but nothing opens. How can I get it to work? What should I provide you with?


I was able to replicate your issue. I am able to start the program from the command line:

mono /usr/share/ssm/Screenshot\ Monitor.exe

This will work as well:

mono '/usr/share/ssm/Screenshot Monitor.exe'

A Log In window appeared.

enter image description here

But I'm not sure why it won't start by clicking on the icon.

I installed it in Ubuntu and it works just fine. You can launch it from the icon. I didn't notice any differences in the respective .desktop files in Ubuntu and elementary OS.

Regarding the message "Gtk-Message: Failed to load module "pantheon-filechooser-module":

There is an answer to that here: Gtk-Message: Failed to load module "pantheon-filechooser-module"

  • Thanks for your swift response! So, I was using Kali and win10 and I had no problem with them. Then, I wanted to try out elementaryOS because it looks just beautiful. However, as I mentioned I couldn't get the program to work so I had to install plank on ubuntu to have almost the same feeling but I really want to go back to elementaryOS. I'll install it alongside ubuntu and if it works, I'll be happy as a child) – codear Nov 20 '18 at 12:04
  • I haven't tried on elementary OS Juno. I only tried it on elementary OS Loki since that is the tag you used. Yes, elementary OS is a beautiful operating system, and it looks like Screenshot Monitor still works if you don't mind running it from the command line. But I can see how that would get old after a while if you use it a lot. – Paul Nov 20 '18 at 17:51
  • Their support's response is: Hello, Please try to start application with terminal command: mono '/usr/share/ssm/Screenshot Monitor.exe' Thank you. Just as you said, it seems that there is no way around this issue. I appreciate your responses. Have a great day! – codear Nov 21 '18 at 8:12
  • No problem. Glad to help. What I find strange is that the command you enter in the terminal is exactly the same as the Exec= statement in the .desktop file. It seems to me it should start by clicking the icon. Weird. – Paul Nov 21 '18 at 17:47
  • Sometimes code is art more than code 😁 – codear Nov 21 '18 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.