I have an old white iMac Core Duo and its running MacOS Lion. It wont allow me to boot of the USB or Disc that have the Elementary OS 5 Flashed/Burned on them. I have tried both the USB and DISC method and once burned to USB or DISC is not recognisable.

I have used the Etcher software to flash the USB but its then unreadable. I have right clicked the ISO and selected Burn to Disc and again once done its not recognisable by my iMac Pro or old White iMac Core Duo.

No idea what I am doing wrong?? Help!! Please.

1 Answer 1


Solved by burning the ISO disc on Windows 10. Running Mojave OSX and it appears the feature to burn a bootable ISO image was removed by Apple for some unknown reason. So OSX users, burn the disc on a Windows 10 machine and it will be fine and bootable.

Etcher software made no difference either on Mojave but did not test on Windows 10 to see if Etcher would flash a USB so that it was bootable. Expect it will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.