I have another problem but with the code editor this time it does not let me create a new tab enter image description here even when I right click and click new tab nothing happens I tried uninstalling it and installing it again but the problem is still there I can't write anything literally enter image description here


I think this is the solution for your problem

Can't open a new tab or new file on scratch

To fix this issue:

  1. Make sure you don't have any unsaved files in Scratch when run as root (with the sudo command). This fix will delete those files.

  2. Open Terminal and use root permissions to remove the directory.

    sudo rm -rf ~/.local/share/scratch-text-editor

  3. Open Scratch as your own user (do not use the sudo command)

Scratch is the old name of Code

With Code the command should be: sudo rm -rf ~/.local/share/io.elementary.code

  • how do i open scratch using terminal @Sebastian
    – pole
    Nov 17 '18 at 6:39
  • 1
    Scratch is the old name of Code (Sorry I asumed you knew), the current command is io.elementary.code. Why you need it?
    – Sebastian
    Nov 17 '18 at 7:07
  • ty sebastian i just changed sudo rm -rf ~/.local/share/scratch-text-editor to sudo rm -rf ~/.local/share/io.elementary.code again ty for the help i appreciate it
    – pole
    Nov 17 '18 at 7:12
  • If it worked then mark it as answered
    – Sebastian
    Nov 26 '18 at 2:12

I had the same issue several times both on Juno and Hera. And usually it worked fine after a fresh install. But I just came to see that sometimes even after a fresh install, it doesn't open. So here is the solution:

Open Terminal

sudo su

cd /home/user/.local/share/io.elementary.code/

(here the "user" is your username on eOS).

chmod 777 unsaved/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.