7

Is there any way to connect my Airplay system to Noise? I know that I can make it work with XMMS2 through a plugin.

I have an AirPort Express which run perfectly with OSX 10.10 and Windows 10.

  • I'm assuming you have an AirPort Express not AirPlay Express (which I could not find anywhere), so I edited it accordingly. – quassy Sep 4 '15 at 1:56
5

I found this solution for Ubuntu, which in theory should work in Freya too.

First install some packages related to PulseAudio (a sound API used by elementary) by typing the following in a terminal:

sudo apt-get install pulseaudio-module-raop pulseaudio-module-zeroconf paprefs

Then start the PulseAudio preferences by typing paprefs and check the two options under Network Access. The window could look similar to this screenshot.

Reboot your system.

Click on the sound indicator and open the sound settings (example screenshot). With a bit of luck you can now select your AirPlay device from the list of available outputs.

Based on answer to "Is there a way to stream audio/video to an Apple Airplay Device?", created by StackExchange contributors.

  • Sorry about the AirPlay mistake an thanks you for your answer. – edu.vicent Sep 9 '15 at 0:20
0

I tried the answer above, and it would not work with my newer Airport Express.

After a lot of reading, it seems that newer devices use UDP rather than TCP. PulseAudio 11+ supports this, however as eOS is based on Ubuntu LTS, there is no easy way to achieve this without compiling a newer PulseAudio yourself.

I managed to compile and install PulseAudio 11.1 and use this rather than the system installed one. Details here:

https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/Developer/PulseAudioFromGit/

The next problem is that Avahi and AirPort don't play well together. If you've enabled detection of AirPlay devices in paprefs, an incorrect IP beginning with 169.* is reported, and this causes playback to fail.

The solution is to disable auto detection in paprefs, and load the RAOP module manually in your ~/.config/pulse/default.pa file, and specify your Airport's IP address.

See julien-gargot's reply here near the bottom:

https://github.com/hfujita/pulseaudio-raop2/issues/21

I used encryption=none option.

Everything now works fine, and I've had no issues! Looking forward to the day when Ubuntu and eOS support this stuff out of the box.

Arch based distros and I presume Fedora will already come with latest PulseAudio 11.1 installed, so you only need to perform the final step of loading RAOP manually.

Regards,

John

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.