1

I have a HP OfficeJet Pro 8710 connected to local network. Worked in Loki flawlessly but I cannot get it to work in Juno.

Pics below show my adding it (its hostname is actually "printer") and while it installs, it shows as disabled in left menu regardless of anything I do on the right side. After clicking "Print Test Page", it does nothing.

enter image description here enter image description here enter image description here enter image description here

2

UPDATE

All of the hp-setup and installation was unnecessary. After new install and updated elementary OS 5.0 Juno, just open up http://localhost:631 in your browser, click on Administration, then Add Printer. Enter your local username and password. Select Discovered Network Printers of choice (in my case HP OfficeJet Pro 8710) and continue with prompts to create printing defaults. This was rather simple printing configuration and the printer was immediately accessible to the applications.

For scanning, I decided to use my printer feature and save all my scans directly to a network share. This way I don't have to bother with cumbersome setup and my scans are available throughout the local network.

Okay, I had a bunch of problems it seems but have gotten it to work now. Some of these steps may not be required, but it serves as a record of my troubleshooting steps that may help someone.

  1. I started by removing (or trying to remove) printer from System Settings. Sometimes removing the printer via - icon did not do anything. Printer was still listed.

  2. As part of troubleshooting process, I ran hp-makeuri from command line. For record, I have version 3.17.10 installed on Juno. I did not have to install any packages in particular. This was already installed on my system. When I tried to do hp-makeuri <IP> I received some SNMP errors. I fixed these by:

    a) installing snmp via sudo apt install snmp command

    b) enabling SNMP on my printer: Network, Advanced, SNMP, Enable SNMPv1/v2 Read-Only access.

  3. During troubleshooting I tried to run hp-setup which gave me dependency errors. I resolved these by installing required sudo apt install python-qt4. I've ran hp-setup to set up network printer. This was okay and it showed up in listed printers again, but I was not able to print a test page to it. I was also not able to remove it from listed printers in System Settings.

  4. Unknown to me before is that you can, on your local system, access http://localhost:631/ web page to manage CUPS where you can manage the print server. I clicked on Administration tab, entered my local username and password, and set up my printer via Add Printer button. Once completed, I clicked Manage Printers and clicked on my newly added printer. To my surprise, my printer was showing to be paused and rejecting jobs. In Maintenance drop-down I have clicked Resume Printer and Accept Jobs. After this printing resumed!

Hope this helps someone. Now, off to get the scanner working...

1

I've got a Konica Minolta PagePro 1300 w connected to a raspberry pi via USB. On the pi CUPS is running for several years now without any problem. The Konica Minolta PagePro is configured as a shared network printer and can be accessed by any device in my network. My Mac instantly discovered the printer and started using it without a problem. Recently I upgraded my laptop to juno. Adding this printer to use under juno on my laptop is quite an adventure. I spent hours to get the job done. Eventually, I found the solution in the CUPS help page:

From CUPS Server in browser choose "Help" -> "Printer Sharing"

or

[https://localhost:631/help/sharing.html?TOPIC=Getting+Started&QUERY=][1]

Manual Configuration of Print Queues

Note: This method of configuration does not work on macOS 10.7 or later because sandboxed applications do not always have direct network access.

The most tedious method of configuring client machines is to configure each remote queue by hand using the lpadmin(8) command:

lpadmin -p printer -E -v ipp://server/printers/printer

The printer name is the name of the printer on the server machine. The > server name is the hostname or IP address of the server machine. Repeat the lpadmin command for each remote printer you wish to use.

Open a terminal session and run

lpadmin -p -E -v ipp://ip_address:port/printer/name_of_printer_in_CUPS

So for me:

chipmunk:~$ lpadmin -p KM_PP1300W -E -v ipp://192.168.3.6:631/printer/KM_PP1300W

did the trick

Unfortunately, the graphical interface in juno was of no use at all for me.

1

I would like to append to C. Fong's excellent four step answer with my experience with a networked HP printer and CUPS. This is how I resolved getting an MFP HP LaserJet M475dw online with network scanning and fax capabilities.

  1. I had to run hp-setup this way

    sudo hp-setup

I had the HP setup GUI screen in the foreground and the terminal screen in the background. My printer needed drivers, before the GUI of hp-setup could continue, I had to answer a few questions and allow the driver download through the terminal screen.

When everything was complete, I had my printer, fax and network scanning capabilities all in place and ready to go! I did notice that Elementary OS Juno does lock down the wingpanel so the HP-Setup icon no longer makes an appearance, but that is OK.

  1. I have used the lpadmin command to install printers in an enterprise environment -- it works like a charm!
  2. To complete my printing experience, I added PDF generation to the CUPS print queue.

    sudo apt install cups-ppdc

0

check /var/log/cups/ for access & error log.

  • There were a lot of non-intuitive logs there. – C. Fong Nov 8 '18 at 6:31
  • any 'idle' 'reject' in error log? – user6308 Nov 8 '18 at 6:45
  • No. Mostly server-error-not-accepting-jobs, client-error-bad-request, CreateProfile and PID 9619 (gutenprint52+usb) stopped with status 1! – C. Fong Nov 8 '18 at 6:51
0

There may be an issue with the PRINTERS App in settings or it's designed to disable and reject jobs on all printers after being idle. I installed SYNAPTIC package manager from the AppCenter. Do a search for switchboard-plug-printers and remove it. Then do a search for and install system-config-printer. You can use it from command line as system-config-printer or you can install the AppEditor from AppCenter and setup an icon in the applications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.