I'm missing 4 icons in AppCenter.

enter image description here enter image description here enter image description here enter image description here

All the other application icons are displayed.

It looks like there was a similar issue in Loki...

App Center missing icons on Loki

..but that looks like it was missing all icons, not just a select few.

Is there a way for me to fix this or is this something for the developers to look at?

Anybody else experiencing this issue? Are they the same missing icons or different ones?

  • I had the same problem right after installing. I had no internet and it didn't update the icons. Then i setup my internet connection, updated and everything went back to normal.
    – Telmo
    Commented Nov 13, 2018 at 9:56
  • I have updated my system, but still have those 4 missing icons. The icons show up in the Application Menu, they just don't show up in AppCenter.
    – Paul
    Commented Nov 13, 2018 at 17:15
  • What is the language in your system?
    – Sebastian
    Commented Dec 1, 2018 at 0:38
  • The language is English.
    – Paul
    Commented Dec 1, 2018 at 0:39
  • I'm having the same issue and am missing the same icons on a fully updated Juno. Has there been any solution that worked for this issue?
    – Chris
    Commented Mar 8, 2019 at 13:17

2 Answers 2


Try the following:

Install App-editor and in each one of those apps, try to search for the icon (in available icons, not manually). This way you can see if the icons are installed in the system. If the icon is available, select it and save each time. That should solve it.

  • The icons are installed. They show up in Slingshot/Application Menu. They also show up in AppEditor. In AppEditor, it doesn't give me the option to save - probably because I'm choosing the exact same icon that it's already using. The icons show up everywhere except AppCenter.
    – Paul
    Commented Nov 14, 2018 at 19:55
  • Change to other icons, save and then change it back and save them again. Weird bug :)
    – Telmo
    Commented Nov 14, 2018 at 21:40
  • I tried changing to a new icon. It changes the icon in Slingshot/Application Menu. I changed it back to its own icon. Again, it changes it in the Application Menu. Nothing gets changed in AppCenter. Yeah, it's weird.
    – Paul
    Commented Nov 15, 2018 at 17:12

If you want to change a icon with AppEdit, you will need to work it with administrator rights or you can change with this command sudo "a file editor like vi" /usr/share/applications/org."filename".desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.