0

A little bit of info for my setups, I have tried this with: live USB, bootable USB, hard drive and I was still getting the same issue across all 3. And this workaround has worked with all as well.

I was trying to get my employer (really small company, I am usually the only one in the building most of the time) to use Elementary OS for the one computer in the office. As I was showing it off, I couldn't get the printer to set up right. I tried everything, even downloading the drivers from the manufacturers website and nothing worked. I eventually ended up installing "system-config-printer" and it worked like a charm. Ran it, it saw the two printers I was trying to add, I said add on one and add on another and they both work just fine without having to go download the drivers, it did that for me (well at least for the two printers I am using). The only thing that I see is that if I change anything dealing with the printer in the printer app that comes with EOS, it will ruin everything that I did and make the printer inoperable. So if you are having the same issue, an easy work around is to install that and off you go. If you do need to change any information about the printer (seriously even something as little as location) don't do it through the program that comes with EOS it will break things.

Install it by running in terminal

"sudo apt install system-config-printer"

Then it won't show in the applications menu, so you are going to have to run it through the terminal just using.

"system-config-printer"

Don't use sudo to run it. I did that once and it only added the printer to the root user, not the user I was on.

And if this does not belong here, I apologize, this is my first time commenting on anything like this.

And if anyone knows a better way to make these things work, let me know. But for now, this works.

I hope that any of this information helps anyone having the same issues as me. And are having a hard time getting the drivers from the manufacturers website to work.

0

You should try to install your printer driver? I lived this problem with Canon Pixma and installed my driver and working perfectly.

  • I tried that with my second attempt to make it work. Downloaded a ".gz" file, unzipped it, then ran it through the terminal using "sudo bash". I just found that this was the easiest way to do it and I wanted to help others who are having the same problem and hopefully letting the creators of EOS know what I found and hopefully they can make things work in the next update. Thank you so much for shooting that idea out. I highly appreciate it. :) With that being said, should I mark this as "answered" or should I leave it be and see if someone else has an idea? – I.R.Baboon Nov 1 '18 at 23:11
  • No, firstly we should find your answer later you can mark right answer and what is your printer full model? EOS abc... – Ramazan Alkan Nov 2 '18 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.