0

I use irsii in terminal, and I would like to use Alt-1, ..., Alt-9 to switch between irssi windows, but these keybindings are already taken from terminal to switch between terminal tabs.

I read this useful answer, and I explored the settings in dconf-editor, but I didn't find anything useful.

2

Thanks to the answer of @"Alex Mitchell", I realized that the alt_changes_tab setting is responsible for the behavior I would like to modify, and I realized that this setting can be accessed and changed through dconf-editor, so I eventually solved my problem.

Edit I mean, changed in the sense that the Alt+num keybindings can be completely disabled, not configured, but this is enough for me.

Edit2 To answer to the comment:

  • install the package dconf-editor, I did it from command line

    sudo apt-get install dconf-editor
    
  • launch the application, it is called Editor dconf,

  • search for the string terminal, clicking on the search tool icon on the upper right part of the window
  • click on /io/elementary/terminal
  • click on settings
  • toggle the switch on the right of the setting on alt-changes-tab
2
  • Could you please outline how you change the shortcuts? Dec 10 '18 at 11:39
  • 1
    @JamieHutber: done
    – enzotib
    Dec 10 '18 at 14:37
1

Unfortunately the terminal shortcuts are hardcoded. I'm not sure if there's plans to make them configurable. To solve your problem, I see two possible solutions:

  1. Modify the source code and compile locally. I see some mention of alt keys here https://github.com/elementary/terminal/blob/master/src/PantheonTerminalWindow.vala#L410. It might be as simple as removing the cases case Gdk.Key.@1: to case Gdk.Key.@9: from the switch statement. There's also instructions on how to compile here https://github.com/elementary/terminal/

  2. Use a different terminal emulator like xterm or gnome-terminal

-1

As you haven't specified which terminal you would like to use, the answer was simply:

sudo apt install gnome-terminal

From here you can set the shortcuts the through the normal preferences.

0

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .