4

I have a stable wi-fi connection at my house. After 5-10 minutes, I can no longer stay connected to the internet. The dock will show that I"m online and connected to the wifi, but nothing loads. I've tried several different browsers and other applications, which require internet connections and nothing. After a restart, everything will work fine... for 5-10 minutes until I get the exact same problems again.

  • 1
    Please edit your question with the output of lshw -c network. – elmato Aug 31 '15 at 9:29
  • *-network description: Wireless interface product: RTL8723BE PCIe Wireless Network Adapter vendor: Realtek Semiconductor Co., Ltd. physical id: 0 bus info: pci@0000:01:00.0 logical name: wlan0 version: 00 serial: 74:29:af:0c:6b:b5 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=rtl8723be – Curtis Sep 1 '15 at 22:39
4

The driver of your wifi card is problematic (almost all of Realtek are) you can try this driver https://github.com/lwfinger/rtlwifi_new

This way:

# Make sure you have the needed tools
sudo apt-get install linux-headers-generic build-essential git

# Close the driver
git clone https://github.com/lwfinger/rtlwifi_new.git

# Enter in the driver directory
cd rtlwifi_new

# Compile
make sudo

# Install
make install

# And finally, reboot
sudo reboot

Source: http://ubuntuforums.org/showthread.php?t=2261702

  • Great, thanks! I'm working on this now. I notice it made a new folder "rtlwifi_new". It made the folder in the personal folder I happened to be in when i started the terminal - /home/myusername/games. Can I move this folder? Should this folder be in my personal folder? – Curtis Sep 2 '15 at 1:55
  • 1
    The folder contains the source code for the driver. Once you run make install it will move the compiled driver to the appropriate place on your system and the folder is no longer required. – elmato Sep 2 '15 at 11:32
  • It worked perfectly. Thank you very much for the helpful information. I'll delete the folder when I get home. – Curtis Sep 2 '15 at 14:28
  • I'm glad to help you, you can accept the answer, that way if someone else has the same problem can find the solution easily. – td18 Sep 2 '15 at 17:07
2

I've got the same problem with the same Wi-Fi card, execute the following command in a terminal:

echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

The issue is the driver going to sleep. This command prevents it by disabling power saving.

0

Which wifi card do you have ? Execute this command in terminal if you don't know : lspci | grep "Network"

  • 01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter – Curtis Sep 1 '15 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.