0

I am having trouble connecting my Microsoft Precision Mouse via bluetooth. I have been having this problem ever since I switched from an ubuntu 16.04 based distro to an ubuntu 18.04 based system (Elementary OS Juno).

I tried adding the mouse via Blueman with the "setup" option and it actually works for a few seconds during the Pairing in progress... screen (see screenshot), but it then displays Failed to add device screen (see screenshot) and at that point, the mouse just stops working again. enter image description here enter image description here

I tried following the answer on this question: https://askubuntu.com/questions/1034246/connecting-microsoft-surface-precision-mouse (which worked on 16.04). But I have had no luck so far...

Any ideas?

1

I figured out a way to fix this, but you need dual boot to windows.

First pair your Precision Mouse to Ubuntu. It doesnt matter if it works or not. Then reboot to windows and pair as usual.

After that reboot to ubuntu and run this python script. https://gist.github.com/Mygod/f390aabf53cf1406fc71166a47236ebf

You need to run it like this python3 ./script.py -s /media/carlos/90C24FB4C24F9D7A/Windows/System32/config/SYSTEM

In this case /media/carlos/90C24FB4C24F9D7A/ is pointing to my mount directory of my windows partition.

After that, the script will create a folder inside your home directory called bluetooth, with a folder with the name of the mac address of your bluetooth adapter and inside that folder there will be folders of each of your bluetooth low energy device. In my case the folder corresponding to the precision mouse is E0:52:2A:96:D2:81.

Now open a new files window as admin. You can do this by right clicking the files shortcut on your dock or on the application menu on the wingpanel.

Then navigate to /var/lib/bluetooth/AdapterAddress/. There you should find a folder with very similar name to the folder created by the script. In my case it was E0:52:29:96:D2:81. Note that the difference is 29 instead of 2A.

Now you should be able to drag and drop the folder created by the script to the /var/lib/bluetooth/AdapterAddress/ directory, and then open the original folder that was created by ubuntu, in my case E0:52:29:96:D2:81 and copy the attributes file into the newly dragged folder.

Let me know if you don't have a windows partition and see if I can manage to make it work without Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.