1

With Elementary OS 5 "Juno" 64 bit GNU/Linux installed on my three gaming PCs, I learned that both my Gigabit Ethernet and 802.11 dual-band AC Wi-Fi keep disconnecting and my VPN encrypted tunnel breaks its connection after I lock the screens or desktop monitor for twenty minutes. Is there a way for me to be able to give you technical information to troubleshoot this issue in order to solve it? I would like to be able to stay connected to the Internet and especially my VPN tunnel as I prefer to keep my PCs turned on most of the time. Is there a way to be able to get Elementary OS 5 "Juno" to do this?

1

These are the solutions that worked for me. I went into greater detail to explain myself and each solution.

I did quite a bit of research so I wanted to share this information with this group if someone else may find it to be helpful or useful.

GNOME 3.28 64 bit has a software flaw in which your desktop or notebook PC will go into suspend or sleep mode after you either lock your screen or leave it at idle for twenty minutes. This means that any GNU/Linux distribution or version that uses GNOME 3.28 64 bit is affected including the older Ubuntu 18.04.x 64 bit LTS, Red Hat Fedora Workstation 28 64 bit and others that use it as well. There are separate but related fixes for GNOME 3.28 64 bit and Elementary OS 5 "Juno" 64 bit that are closely related that will solve this problem. I am going to share the solution that worked for me for Elementary OS 5 "Juno" 64 bit GNU/Linux in this post.

To fix the problem with locking your screen that causes your Ethernet or 802.11 Wi-Fi to disconnect after twenty minutes, follow these instructions step by step:

1a. Open up the terminal
1b. Type in sudo -s
1c. Type in your root password
1d. Type in su -s /bin/bash lightdm
1e. Type in dbus-launch gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type
1f. Type in dbus-launch gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout
1g. Type in exit
1h. Type in exit again
1i. Type in exit once again to close the terminal

To fix the problem with your desktop or notebook PC going to sleep or suspend mode after twenty minutes:

2a. Open up the terminal
2b. Type in dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type nothing
2c. Put in your root password
2d. Type exit to close the terminal
2e. Restart your desktop or notebook PC for these changes to take into effect

To verify that these two important fixes do work, I own three gaming PCs: 1. mid-2017 AVA Direct, 2. mid-2017 ASUS ROG STRIX GL702ZC and 3. mid-2016 Acer Predator 17X (GX-791). Elementary OS 5 "Juno" 64 bit GNU/Linux is installed and updated on each gaming PC not to mention a healthy list of both free and open source and third-party closed source and proprietary software products. I decided to test these solutions by connecting to VPNSecure.Me to different VPN gateway servers in the United States of America and I locked my screens and I waited for thirty minutes. After that period of time elapsed, I unlocked my screens and I double checked to verify that my gaming PCs had not gone into sleep or suspend mode which they did not and that my VPN encrypted tunnels were still connected which they still are connected at this time.

Make sure to restart your desktop or notebook PCs after committing these changes in the terminal so that the changes take into effect after each PC restarts itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.