0

Today I installed Juno on a low-end 2016 Asus laptop with Intel i5 processor. I know nothing about Linux, this was just to replace a very slow Windows 10.

When I connect TV with HDMI, I get picture but no sound. I installed Pulse Audio Volume Control, as suggested on some Ubuntu forums, and when I manually chose "HDMI 2" as output, it worked. But only until the next time I connected the cable.

Any way to make it permanent? Is it possible to install some better drivers or software?

  • By the way, in the default Sound app I only see "Speakers" as output, no HDMI... – Przemator Oct 27 '18 at 20:44
1

This seems to be a limitation (bug?) of the current sound setting app. The current workaround is to install PulseAudio Volume Control from the AppCentre, and to select a HDMI configuration profile.

Select Profile from Configuration Tab

References:

  • Hi Ifaz. Thanks for your reply. Notice I already mention Pulse Audio in my original post, so I know about the workaround and it also works for me. It's just that it's totally inconvenient to set it every time you want to connect the HDMI cable. – Przemator Nov 7 '18 at 7:38
  • Opps, I must have mixed this with another post which didn't already mention Pulse Audio when responding. I'm going to leave the response here for now for anyone looking for a step-by-step solution. – Ifaz Kabir Nov 9 '18 at 6:42
  • @IfazKabir I figured this out before seeing your answer, but also came at it slightly differently. I ran aplay --list-devices to see that the HDMI devices were recognized by the system, also pactl list to see they are available; then sudo apt-get install pavucontrol, and selected one of the HDMI profiles for the Built-in Audio. At least you don't have to do that for Bluetooth headphones. I upvoted your answer because it would have probably helped if I found it earlier. – hlongmore Nov 21 '18 at 6:59
1

We can use command

pactl

pactl - Control a running PulseAudio sound server on terminal

first, list our available properties in our machine using this command:

    pactl list cards

enter image description here

based on my hardware above, i set output:hdmi-stereo as my default profile using this command:

pactl set-card-profile 0 output:hdmi-stereo

if we want to set to internal output(in my case my laptop), use this command:

 pactl set-card-profile 0 output:analog-stereo

and magically, in sound settings is gonna be like this. sound settings going normal again

I hope this can help.more detail about pactl command use this command:

pactl -h

or check manual page:

man pactl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.