I've recently installed Juno and I simply love the clean design. Kudos. The issue I'm having is trying to connect to my work VPN. I installed openconnect and NetworkManager-openconnect, but the only option I see when adding a new VPN connection is OpenVPN. I'm specifically looking for Juniper or Cisco compatible connections.

I was able to connect via terminal. In all honesty I'm not sure if it worked. Is that the same thing as having a connection through the GUI. It's a silly question, but doing VPN outside of a GUI is new to me.

openconnect --juniper URL -u USERNAME

I'm new to Pantheon desktop and all my search results aren't helping. I figured since the desktop was based on GNOME that the process would be the same on my Fedora box, but it's different. What am I missing here? Thanks.

2 Answers 2


On Juno (which is based on Ubuntu 18.04) you should be able to follow this guide: https://grepitout.com/install-openconnect-ubuntu-vpn-client/

The GUI in elementary will look a bit different, but the funtionality is the same. I tried it myself on a VirtualBox Juno installation and it worked like a charm :)

  • Thank you, this worked. Apparently what I missed was network-manager-openconnect-gnome.
    – fergatron
    Commented Oct 29, 2018 at 17:52

You need to choose the PPTP protocol

PPTP protocol

Then just enter your login credentials on the new window:

login credentials

  • 1
    Thank you for the screenshots. It didn't fix my issue specifically, but it helped me see that I was limiting myself to what I thought was the solution.
    – fergatron
    Commented Oct 29, 2018 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.