I did a fresh install of Juno on a laptop that I previously used with Loki. However, after the installation finishes and the laptop reboots, I get just black screen with a message about missing boot device (see screen 1).

Screen 1

After pressing Enter, I get to a second screen with list of two options - shim and grub. Choosing any of them returns me to screen 1. In other words - I cannot boot into the freshly installed system.

Screen 2

If I insert live USB (created using the MultiBoot tool that I successfully use for years), it sometimes shows a new option on the list with name of my USB drive. Selecting it sends me to MultiBoot menu, where I can boot into my live Linux distributions.

If I start a live session of, e.g., elementary OS, I can see that the /boot/efi folder of the installed system is completely empty. This shouldn't be the case as I have UEFI and secure boot enabled (I had this setup in Loki too).

I remember that I had booting problems on this machine also after installing Loki, however based on my notes and weak memory I solved them quite easily by just selecting both shim and grub options consecutively. This however doesn't have any effect in Juno.

Is there a way to fix this e.g. by copying the missing files from somewhere in the live session? And if so, from where can I copy these files?

System: Acer Aspire One Cloudbook 11 - netbook with 32 GB eMMC storage with those weird partition names like mmcblk0 or mmcblk0boot0 instead of (I guess) sda or sda1 (respectively). sudo parted -l shows two partitions on mmcblk0 - one fat32-formated EFI partition and one ext4-formated partition with the installed system.


I tried to run Boot Repair utility from LiveUSB and it didn't work, the log is here: http://paste.ubuntu.com/p/f72xMvBTtn/ (dropbox backup: https://www.dropbox.com/s/vk16exwmcmorj5x/boot-repair_cloudbook.txt?dl=0)

I also found a thread on Linux Mint forums with almost identical symptoms (Acer laptop, same error message, no access to BIOS, only his OS is 16.04-based): https://forums.linuxmint.com/viewtopic.php?t=269299

However I cannot access BIOS (I don't have older version of Juno available, like he had with LM) so I cannot use his solution.

1 Answer 1



My main problem was that I was unable to access the BIOS, as the normal method for my laptop didn't work (i.e., when the laptop is OFF, press & hold F2 and turn it ON, keep holding F2 until the BIOS shows up).

However, today after some new desperate attempts with boot-repair, I tried enter the BIOS the way it's normally done on other laptops (i.e., turning it on and then press F2 like crazy) - and voilà - it worked!

In the BIOS, I had to do a few things suggested in the link to Linux Mint forum:

  1. Reset Secure boot to factory settings
  2. Erase Secure boot configuration
  3. F10 to save and reboot (this was crucial)
  4. Enter the BIOS again and select three EFI files from my EMMC drive (from within the ubuntu folder) and give them different descriptions:
  • shimx64.efi
  • grubx64.efi
  • fwupx64.efi
  • Note: I've used name of each file without "x64.efi" as description. But it was important to have the descriptions unique.
  1. F10 to save and a final reboot.

After this, I was greeted with the elementary OS logo :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.