0

Under Loki, my HP LaserJet 1012 connected and worked without any setup or issues but under Juno it doesn't seem to want to connect. Any ideas on how to get it working? I tried the add a printer button but it didn't seem to want to work afterwards.

  • Where did you try it before? – Maccer Oct 23 '18 at 19:17
  • I'm not sure what you're asking. I just backed up my data and did a nuke and pave on the same system to upgrade from Loki to Juno and now my printer doesn't work where it did before. Same printer, same computer, same USB connection. I've tried disconnecting/reconnecting and turning the printer off/on as well as the aforementioned add printer button in the printer menu (and interestingly enough it does see the printer there but it doesn't print after I select it) and nothing. It doesn't let me print anything. – Vanessa Oct 23 '18 at 19:19
  • I was asking what OS you where using before. But you just told me anyway. Try to add your printer directly from cups: open a web browser and type: http://localhost:631/ then fiddle with the settings. – Maccer Oct 23 '18 at 19:25
  • I'm not trying to print from a network, I'm trying to print from the local computer. The printer isn't showing up in the printer menu at all. – Vanessa Oct 24 '18 at 22:32
  • It doesn't matter. That link opens a configuration page for CUPS. From there you can do anything related to your computer. – Maccer Oct 25 '18 at 20:44
1

I found a fix. I manually added the printer using the + button on the printer menu in Settings and finding it in the list, then enabled it and set it as default. Then I opened the terminal and used lpq to configure it.

The commands I used are:

lpq enable

lpq up

Then I was able to print from LibreOffice without issues.

0

I just reinstalled the laptop from Loki to Juno...

I got the problem with that my phone is not charging anymore when i will connect the cable to the laptop.

What happens - i will connect the phone to the usb, phone will show charging, juno will show the accessible device in device-list of files, ...and in one second phone is disconnected from power and stop charging. When i will click in device list to open this phone, it will "mount" the phone even if the phone is selected to "charging mode" and in that moment phone is charging again.

I think it is the same issue with your printer.

Probably Juno will try to read-up the connected device for a second and after that it is turning off the powersupply to device... :/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.