3

When closing atom when it's resized to fullscreen, then restarting atom doesn't result in a window.

Use the following steps to reproduce:

  1. Install atom from the deb (https://atom.io)
  2. Set Atom to fullscreen
  3. Close Atom
  4. Restart Atom. It starts but there is no window...

To get the window back use super + up (restore window size).

See the following gif, on a fresh virtualbox installation with a fresh atom install. gif

3

The same thing also happens with Brave (browser). It's clear that the window is maximized, as the panel at the top becomes black. If you click and drag down just below the black panel, the program window restores to a non-maximized size and becomes visible. If you maximize it again, it'll work correctly until will close the window again.

  • Perhaps it only happens with electron apps? – dietervdf Oct 23 '18 at 4:32
  • Maybe not. FontBase is also an electron app and works correctly (though it's not installed, as it's an AppImage file). – racporto Oct 23 '18 at 16:23
1

System Settings > Keyboard > Shortcuts > Windows > Unmaximize

Mine defaults to Alt F5

Thanks a ton for posting. I reinstalled Atom 3 times before finding this.

0

I have found that enabling logging when you open up Atom stops this from happening most of the time.

atom -l ~/atom-log.txt

You can set an alias in your ~/.bashrc file to make launching Atom from the terminal with the config easier.

printf '\nalias atom="atom -l ~/.atom/log.txt"' >> ~/.bashrc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.