0

When i use the shortcut keys Win+L, click the Lock option in wingpanel-session menu, or when i suspend, lock doesn't work.

dm-tool lock works. light-locker-command --lock shows:

Received error message from the locker: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ScreenSaver was not provided by any .service files

If i install gnome-screensaver lock screen works for sleep and shortcut keys, but not from the wingpanel-session menu. It also displays differently.

Any idea how to get this working? I just fresh-installed Elementary (Juno).

  • I couldn't solve the problem, so i just installed Elementary again and it has been working so far. – Telmo Nov 1 '18 at 12:03
1

remove disable-light-locker package from the system.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.