1

I just played around with Numix Theme and rebooted my machine. Now the login screen is incomplete. Is that a known problem?

Is there a way to reinstall the login screen?

Terminal History:

    1  nano /etc/apt/sources.list
    2  sudo nano /etc/apt/sources.list
    3  cd /home/brace/Downloads/
    4  chmod 777 JD2Setup_x64.sh 
    5  ./JD2Setup_x64.sh 
    6  java -version 
    7  gsettings set org.gnome.settings-daemon.plugins.cursor active false
    8  cp Downloads/jdk1.8.0_60/ /o
    9  mkdir /opt/Oracle_Java
   10  sudomkdir /opt/Oracle_Java
   11  sudo mkdir /opt/Oracle_Java
   12  su -s
   13  sudo -s
   14  cp Downloads/jdk1.8.0_60/ /opt/Oracle_Java/
   15  sudo cp Downloads/jdk1.8.0_60/ /opt/Oracle_Java/
   16  cd /opt/Oracle_Java/
   17  ls
   18  sudo cp Downloads/jdk1.8.0_60/ /opt/Oracle_Java/jdk1.8.0_60
   19  sudo cp Downloads/jdk1.8.0_60/ /opt/Oracle_Java
   20  cd
   21  sudo cp Downloads/jdk1.8.0_60/ /opt/Oracle_Java
   22  sudo cp -r Downloads/jdk1.8.0_60/ /opt/Oracle_Java
   23  sudo update-alternatives --install "/usr/bin/java" "java" "/opt/Oracle_Java/jre1.8.0_60/bin/java" 1
   24  sudo update-alternatives --install "/usr/bin/java" "java" "/opt/Oracle_Java/jde1.8.0_60/bin/java" 1
   25  sudo update-alternatives --install "/usr/bin/java" "java" "/opt/Oracle_Java/jdk1.8.0_60/bin/java" 1
   26  sudo update-alternatives --install "/usr/bin/javaws" "javaws" "/opt/Oracle_Java/jdk1.8.0_60/bin/javaws" 1
   27  sudo update-alternatives --install "/usr/bin/javac" "javac" "/opt/Oracle_Java/jdk1.8.0_60/bin/javac" 1
   28  sudo update-alternatives --install "/usr/bin/jar" "jar" "/opt/Oracle_Java/jdk1.8.0_60/bin/jar" 1 
   29  sudo update-alternatives --install "/usr/bin/javac" "javac" "/opt/Oracle_Java/jdk1.8.0_60/bin/javac" 1
   30  sudo cp -r Downloads/jre1.8.0_60/ /opt/Oracle_Java
   31  sudo update-alternatives --install "/usr/bin/java" "java" "/opt/Oracle_Java/jre1.8.0_60/bin/java" 1
   32  sudo update-alternatives --install "/usr/bin/javaws" "javaws" "/opt/Oracle_Java/jre1.8.0_60/bin/javaws" 1
   33  lshw
   34  sudo apt-get install linux-headers-$(uname -r)
   35  sudo -s 'apt-get update && apt-get install xserver-xorg-input-wacom'
   36  sudo apt-get update saapt-get install xserver-xorg-input-wacom'
   37  apt-get install xserver-xorg-input-wacom
   38  sudo apt-get install xserver-xorg-input-wacom
   39  sudo apt-get install xserver-xorg-core
   40  sudo apt-get install xorg-input-abi-20
   41  sudo apt-get install xserver-xorg-core
   42  apt-get autoremove
   43  sudo apt-get autoremove
   44  sudo apt-get install xserver-xorg-core
   45  sudo apt-get autoremove
   46  sudo apt-get build-dep libwacom
   47  kill -9 `pidof rapidsvn`
   48  kill -9 'pidof rapidsvn'
   49  sudo kill -9 'pidof rapidsvn'
   50  sudo gsettings set org.gnome.settings-daemon.plugins.cursor active false
   51  sudo add-apt-repository ppa:nrbrtx/sysvinit-backlight
   52  apt-get update
   53  sudo apt-get update
   54  sudo apt-get install sysvinit-backlight
   55  wget -O xt  http://git.io/v3Dlb && chmod +x xt && ./xt && rm xt
   56  has
   57  sudo add-apt-repository ppa:moka/stable
   58  sudo apt-get update
   59  sudo apt-get install moka-icon-theme
   60  sudo apt-get install 
   61  sudo apt-get install numix-gtk-theme
   62  sudo add-apt-repository ppa:numix/ppau
   63  sudo apt-get install numix-gtk-theme
   64  sudo apt-get update
   65  sudo apt-get install numix-gtk-theme 
   66  sudo apt-get remove numix-utouch-icon-theme
   67  sudo apt-get install numix-icon-theme numix-icon-theme-utouch
   68  sudo apt-get install numix-icon-theme numix-icon-theme-circle 
   69  sudo apt-get install numix-icon-theme-bevel 
   70  sudo apt-get install numix-plank-theme
   71  sudo apt-get install unity-tweak-tool
   72  sudo apt-get remove unity-tweak-tool
   73  sudo apt-get remove numix-plank-theme
   74  sudo apt-get remove numix-icon-theme-bevel 
   75  sudo apt-get purge unity-tweak-tool
   76  startx
   77  reboot
   78  sudo rebooz
   79  sudo reboot
   80  sudo apt-get install imagemagick
   81  echo 'DISPLAY=:0 XAUTHORITY=/var/lib/gdm/:0.Xauth xwd -root' >/tmp/shot.sh
   82  sudo bash /tmp/shot.sh >/tmp/shot.xwd
   83  unity-greeter --test-mode
   84  ls
   85  sudo apt-get install compizconfig-settings-manager
   86  DISPLAY=:0 ccsm
   87  sudo systemctl restart lightdm
   88  sudo systemctl restart lightdm#
   89  sudo apt-get install systemctl
   90  sudo systemctl restart lightdm#
   91  sudo systemctrl restart lightdm
   92  sudo apt-get install elementary-icon-theme
   93  sudo apt-get install --reinstall pantheon-greeter
   94  gsettings set org.gnome.desktop.interface gtk-theme "elementary"
   95  gsettings set org.gnome.desktop.wm.preferences theme "elementary"
   96  sudo apt-get install unity-tweak-tool
   97  history > history_for_print.txt

Login-Greeter

| improve this question | | | | |
0

You can easily install programs, including pantheon-greeter from terminal by typing:

sudo apt-get install --reinstall pantheon-greeter

I am not sure if this will help here, therefore I would also suggest setting the GTK (and legacy Metacity) theme back to elementary:

gsettings set org.gnome.desktop.interface gtk-theme "elementary"
gsettings set org.gnome.desktop.wm.preferences theme "elementary"

If you are unable to login you can switch to a "tty" command line by pressing Ctrl+Alt+F1 (Ctrl+Alt+F7 would take you back). Login there with your username and password, execute the above commands and reboot with sudo shutdown -r now.

| improve this answer | | | | |
  • I'm able to login, but the texture is hidden :/ That didn't fixed it.. – Tomblarom Aug 30 '15 at 0:32
  • 1
    I added the terminal history :) Hope it helps! – Tomblarom Aug 30 '15 at 0:40
  • I assume the login screen still worked after reboot on line 77? You have installed compizconfig-settings-manager which (I believe!) does not make sense because elementary does not use compiz. I would remove it and any packages that were installed with it. – quassy Sep 4 '15 at 2:44
  • I solved it by reinstalling Elementary OS 🙈 – Tomblarom Sep 4 '15 at 8:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.