1

This question already has an answer here:

I've got a Thinkpad X1 Carbon 4th gen with a 1080p 14" display. My default (max) resolution is 1920x1080. It looks good in Elementary 5.0, although fonts are a bit too small. So i installed Elementary Tweaks and increased font size. Then i changed font size for Firefox... and everything looked perfect. Then i installed Cisco PacketTracer, Anaconda, Spyder and RStudio. They look huge! Then i found out that if i decrease my screen resolution to 1600x900, these apps look really nice, but the app menu (slingshot?) occupies more than half my display height.

I've tried using 1920x1080 with xrandr --output eDP-1 --scale 0.9x0.9 and it's really good, except the fonts are all blurred, and it feels like i need glasses. I've also tried 1600x900 with xrandr --output eDP-1 --scale 1.2x1.2, which theoretically also looks good, but the mouse is restricted to an invisible border and i can't reach the right-end as well as the bottom of the display with the cursor.

So... I wouldn't mind using 1600x900 if i could only reduce icon size in the app menu. But i need to figure this out. I've tried to make the fonts look crispy, tried to figure out how i could solve the mouse border problem... tried everything. It's crazy how many forums i've searched, even other linux distros. Can't seem to find anything that can help me out.

Any ideas, anyone? Is it possible to enable scaling to specific apps? It has been a nightmare. I need to use these apps for school and can't use them correctly.

enter image description hereenter image description here

With xrandr --output eDP-1 --scale 1.2x1.2 it looks like this:

enter image description here

marked as duplicate by Peter Uithoven, Lewis Goddard Nov 30 '18 at 19:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

You can try to use the --panning Option for xrandr.

If you set

xrandr --output eDP-1 --scale 1.2x1.2

for the 1600x900 Resolution, you have to add the panning Option

xrandr --output eDP-1 --panning 1600x900

This will increase the Mouse Area.

  • Thank you for your answer but it appears Gnome is not yet ready for fractional scaling. I added another screenshot to my post, please check it out. Sometimes when i use 'xrandr --output eDP-1 --scale 1.2x1.2' it works, sometimes it's displayed as above. And even when it works, fonts look blurred (something i haven't noticed before for some reason). – Telmo Oct 22 '18 at 20:53
  • I can't get it to work on my Device, too. I have an 12" Tablet with a mixed-dpi? Screen. I try the xrandr Tweaks, which doesn't work well. The 1x and 2x Option in Gnome and Elementary is not an Option for me because it is to small or to big. I ended up using a custom Resolution. It works, but the fonts are blurry too. I think KDE is the only Desktop which work great with fractional scaling. But it is not Elementary :/ – Dorban Oct 23 '18 at 10:58
  • Exactly. It appears to happen with all QT apps that run in gnome at a mixed dpi setting. I tried running in terminal QT_SCALE_FACTOR=0.5 <appname> and apparently works. But the factor changes according to each app. So i'm thinking in adding that to a .desktop file for each app with a specific scaling factor. I only use about 4 or 5 QT apps, so, it shouldn't be very difficult to implement... i hope. – Telmo Oct 23 '18 at 11:46
  • I was thinking in going back to Arch and use KDE, but i'm very fond of Pantheon and KDE is a little resource hungry for my taste. – Telmo Oct 23 '18 at 12:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.