1

I get an error when I try to open dropbox or sopcast-player:

Starting Dropbox...Gtk-Message: Failed to load module "pantheon-filechooser-module"
Gtk-Message: Failed to load module "pantheon-filechooser-module"
Attempt to unlock mutex that was not locked
Aborted (core dumped)

I tried all in this topic, but still get the error. I tried also to update gtk to version 3. My OS is updated to the newest version.

What can I do to solve this issue?

1

You will always get an error about not being able to load the file chooser module with legacy gtk2 apps or with qt apps.

The "Mutex" bit is the part that's causing problems. This is related to an upstream bug in Gtk (See this bug report) and doesn't seem to affect the version of dropbox available from software center (as reported in this bug report).

1

The topic seems a little outdated but following solved the problem for me on elementary OS 0.3.1 Freya 64-bit. Hope that helps.

1) Uninstall dropbox if you have previously installed from the deb package like me;

sudo apt-get remove dropbox

2) Install nautilus-dropbox package;

sudo apt-get install nautilus-dropbox

3) After the installation is completed, start Dropbox by clicking its icon from the Applications menu and put your credentials (that also makes the panel icon visible)

4) Right click the icon on the panel and go to Preferences. Remove the selection for the option "Start Dropbox on system startup"

5) Go to Applications from elementary os "System Settings". On the startup tab click "+" to add a custom command and type the command below;

env XDG_CURRENT_DESKTOP=Unity dropbox start

6) Logout and log back in, dropbox should run and start syncing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.