0

I'm experiencing weird behaviour with my wireless Dell keyboard. After pairing it seems to be stuck in a connection loop. It's added again and again until I turn it off. What's more, other bluetooth devices are blocked as well. Here is a GIF to illustrate the issue:

enter image description here

Luckily, the keyboard and mouse come with a USB dongle, which works fine. Only on direct bluetooth connections (channel #2 and #3) there is this problem. The mouse, on the other hand, works perfectly fine on the dongle channel as well as on the two bluetooth channels. And so does my Microsoft Surface keyboard, no problems there.

I used the Dell keyboard on a daily basis with Pop!_OS on this same laptop. It also works fine with my Mac and all my other devices. It's just behaving badly on elementaryOS.

A solution would be to buy another surface keyboard, but clearly it's a software issue so maybe there is an easy fix?

0

In my situation the initial keyboard recognition [it did "see" the KB] was stuck in my Elementary OS bluetooth panel and it would neither connect nor could I delete it. (I thought that deleting it from the panel might allow me to start trying to Pair from scratch - refreshed.) But, I could never delete it even after turning the KB [keyboard] off and rebooting the computer.

This morning I tried this: 1. Turn on the KB and make sure it's in Pairing mode (Press & hold power button until power light starts flashing.) (Obviously I'm using a wired KB to accomplish these steps.) 2. Select it in the Elementary OS Control Panel and click the Pair button; 3. Wait a moment [a second or two but no more] and type "0000" then Enter; 4.Repeat this process a few times offsetting the delay time [when you enter the "0000" pass-phrase], just a bit +/-, each time.

This finally worked for me and I'm back in business with BT KB and trackpad. When you power up your BT KB you might try to first delete it from the "Nearby Devices" list before you start - if possible. I'd be very interested to know if this works for you. If EOS is recognizing most BT devices then we just need the developers to implement an additional step thata will tell the user whether or not EOS is requiring a pass-phrase. With BT keyboards it definitely is, but there's no prompt that makes it obvious.

  • Thanks for the elaborate answer. I tried it a few times but without luck. The duplication happens every time as soon as I hit the pair button. – wout Oct 24 '18 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.